sshd killed

Daniel Balsiger dbalsige at iamexwi.unibe.ch
Mon Dec 12 05:52:44 PST 2005


hello HLFS developers

Thank you for the great HLFS project!!

I have built an HLFS SVN-20051206 yesterday.
I have libxcrypt installed as suggested by
blowfish-passwords hint.
everything works well, except one thing:
can't login via ssh:

-bash-3.00# ssh localhost
socket: Address family not supported by protocol
root at localhost's password:
grsec: denied resource overstep by requesting 8392704 for RLIMIT_STACK \
       against limit 8388608 for /usr/sbin/sshd[sshd:10756] ........
grsec: signal 11 sent to /usr/sbin/sshd[sshd:10756] uid/euid:0/0 \
       gid/egid:0/0, parent /usr/sbin/sshd[sshd:3554] uid/euid:0/0 gid/egid:0/0
grsec: denied resource overstep by requesting 4096 for RLIMIT_CORE against \
       limit 0 for /usr/sbin/sshd[sshd:10756]
Connection closed by 127.0.0.1
-bash-3.00#

I think the sshd child is requesting stack of 8392704 because of the
blowfish-passwords. This never happened before, it worked with several
older HLFS versions and kernel 2.6.11.12-grsec.

What I have to do that my sshd lets me in ?
What I have to do to raise RLIMIT_STACK for sshd only ?

I tried a "sshd -" line im /etc/limits, but that didn't help.

thx in advance

daniel



More information about the hlfs-dev mailing list