Wrong patch reference in chapter07/kernel.xml

Tobias Stoeckmann tobias at bugol.de
Sat Dec 10 05:12:54 PST 2005


Hi hlfs-developers,

I have noticed a wrong patch reference in chapter07/kernel.xml:

"grsecurity-2.1.7-2.6.14.3-200511261227.gz"

should be

"grsecurity-2.1.7-2.6.14.3-200511261227.patch.gz"

I have applied a patch that writes the version of grsecurity into
general.ent. Is there a reason this has not been done (or should not
be done)?

--- general.ent~	Sat Dec 10 14:04:48 2005
+++ general.ent	Sat Dec 10 14:06:01 2005
@@ -39,6 +39,7 @@
 <!ENTITY glibc-version "2.3.6">
 <!ENTITY grep-version "2.5.1a">
 <!ENTITY groff-version "1.19.1">
+<!ENTITY grsecurity-version "2.1.7-2.6.14.3-200511261227">
 <!ENTITY grub-version "0.97">
 <!ENTITY gzip-version "1.3.5">
 <!ENTITY hotplug-version "2004_09_23">


--- chapter04/patches.xml~	Sat Dec 10 14:04:23 2005
+++ chapter04/patches.xml	Sat Dec 10 14:06:29 2005
@@ -200,7 +200,7 @@
 <varlistentry>
 <term>GR Security Patch - ?? KB:</term>
 <listitem>
-<para><ulink url="http://www.grsecurity.net/grsecurity-2.1.7-2.6.14.3-200511261227.patch.gz"/></para>
+<para><ulink url="http://www.grsecurity.net/grsecurity-&grsecurity-version;.patch.gz"/></para>
 </listitem>
 </varlistentry>
 

--- chapter07/kernel.xml~	Sat Dec 10 14:03:36 2005
+++ chapter07/kernel.xml	Sat Dec 10 14:07:16 2005
@@ -57,14 +57,14 @@
 <quote>as</quote> kernel tree:</para>
 
 <screen><userinput>install -m444 /sources/linux-&linux-version;-pseudo_random-1.patch /usr/src
-install -m444 /sources/grsecurity-2.1.7-2.6.14.3-200511261227.gz /usr/src
-gunzip /usr/src/grsecurity-2.1.7-2.6.14.3-200511261227.gz</userinput></screen>
+install -m444 /sources/grsecurity-&grsecurity-version;.patch.gz /usr/src
+gunzip /usr/src/grsecurity-&grsecurity-version;.patch.gz</userinput></screen>
 
 <para>Then change to the Linux source directory and apply the patches:</para>
 
 <screen><userinput>cd /usr/src/linux-&linux-version;
 patch -Np1 -i ../linux-&linux-version;-pseudo_random-1.patch
-patch -Np1 -i ../grsecurity-2.1.7-2.6.14.3-200511261227</userinput></screen>
+patch -Np1 -i ../grsecurity-&grsecurity-version;.patch</userinput></screen>
 
 <tip><para>Look at <command>info libc</command>, node <quote>System 
 Configuration</quote>, <quote>General Limits</quote>. There are


Tobias Stoeckmann



More information about the hlfs-dev mailing list