Glibc-2.3.3-lfs-5.1? (was Re: QLFS project announcement)

Robert Connolly robert at linuxfromscratch.org
Wed Sep 1 09:43:37 PDT 2004


On August 28, 2004 10:38 am, J. Scott Edwards wrote:
> I guess I have answered that question, the pt_pax patch fails.  As far as
> I can tell because of PT_GNU_RELRO not being there.

The glibc-2.3.3 from gnu.org is missing relro and fpie features. Binutils-2.15 
doesn't have the relro feature so in that aspect it doesn't matter, but I've 
been trying to build gnu's glibc-2.3.3 for the past few days without luck, it 
always either doesn't build or fails the testsuite in chapter 6 (trying with 
gcc-3.3.3, 3.3.4, and 3.4.1). I think it was made to be patched. The 
glibc-2.3.3-lfs-5.1 tarball works much better. I haven't had luck with the 
recent cvs tarballs in lfs-unstable either, I'm not sure if gcc-3.3.4 is 
causing errors. There are a lot of possible upgrades for the toolchain, I 
haven't found which is stable.



More information about the hlfs-dev mailing list