FTP server?

J. Scott Edwards sedwards at xmission.com
Tue Jul 20 06:05:23 PDT 2004


On Tue, 20 Jul 2004, Miguel Bazdresch wrote:

> * J. Scott Edwards <sedwards at xmission.com> [2004-07-20 09:00]:
>>
>> I have tried to build it using that latest book, but I just can't get past
>> the glibc make check in chapter 6 (I did not run any checks in chapter 5).
>> I've tried it three times now, starting from chapter 5.  At first I was
>> trying to use GCC 3.3.4 because at first I couldn't find the sources for
>> 3.3.3 and it seemed to patch and work ok.  But when glibc kept failing I
>> went back and did it all over again with GCC 3.3.3 and it gets the same
>> error:
>>
>> sedwards at marconi tmp $ more
>> /mnt/lfs/sources/glibc-build/math/test-ifloat.out
>> testing float (inline functions)
>> Failure: Test: hypot (0.7, 12.4) == 12.419742348374220601176836866763271
>> Result:
>>  is:          1.24197416305541992188e+01   0x1.8d6e8600000000000000p+3
>>  should be:   1.24197425842285156250e+01   0x1.8d6e8800000000000000p+3
>>  difference:  9.53674316406250000000e-07   0x1.00000000000000000000p-20
>>  ulp       :  1.0000
>>  max.ulp   :  0.0000
>>
>> It says there were 9 errors (but I only see eight in the file).  I don't
>> know where to go from here.  I could swear I have followed the hlfs book
>> exactly.
>
> I haven't followed all the thread; sorry if I'm missing something. Do
> you have a recent intel or amd cpu? Some models are known to fail some
> math tests. If all your errors are in the math tests and your cpu is
> old/not intel then i'd say it's safe to go on.

No worries, the previous parts of the thread don't have much to do 
with this.

It's a 3 GHz Pentium 4.

After I sent the mail last night I decided to see what happened if I 
continuted the "make check".  If went a little further and then failed on 
dlfcn and I don't even know what that is:

GCONV_PATH=/sources/glibc-build/iconvdata LC_ALL=C 
/sources/glibc-build/elf/ld-linux.so.2 --library-path 
/sources/glibc-build:/sources/glibc-build/math:/sources/glibc-build/elf:/sources/glibc-build/dlfcn:/sources/glibc-build/nss:/sources/glibc-build/nis:/sources/glibc-build/rt:/sources/glibc-build/resolv:/sources/glibc-build/crypt:/sources/glibc-build/linuxthreads 
/sources/glibc-build/dlfcn/default  > 
/sources/glibc-build/dlfcn/default.out
make[2]: *** [/sources/glibc-build/dlfcn/default.out] Error 1
make[2]: Leaving directory `/sources/glibc-2.3.3-lfs-5.1/dlfcn'
make[1]: *** [dlfcn/tests] Error 2
make[1]: Leaving directory `/sources/glibc-2.3.3-lfs-5.1'
make: *** [check] Error 2

root:/sources/glibc-build# cat /sources/glibc-build/dlfcn/default.out
default.c: dladdr returned '' as dli_fname
default.c: main correctly found
default.c: found_in_mod1 correctly found
default.c: found_in_mod2 correctly found
defaultmod1.c: main correctly found
defaultmod1.c: found_in_mod1 correctly found
defaultmod1.c: found_in_mod2 correctly found
defaultmod2.c: main correctly found
defaultmod2.c: found_in_mod1 correctly found
defaultmod2.c: found_in_mod2 correctly found

The strange thing here is I don't see any errors in the output file.


> Also double-check you don't have CFLAGS set before compiling glibc.
>

I had CFLAGS set at first and the last couple of builds have been without 
them.  I just double checked and there are no CFLAGS or CXXFLAGS in my 
environment.

Thanks
    -Scott





More information about the hlfs-dev mailing list