PIE and gcc2

Robert Connolly cendres at videotron.ca
Sun Feb 22 05:07:50 PST 2004


On February 22, 2004 12:08 am, Archaic wrote:
> On Sat, Feb 21, 2004 at 04:00:47PM -0500, Robert Connolly wrote:
> > gcc2 is the only thing left that won't be PIE. What do you guys think
> > about ditching gcc2?
>
> It's getting to the end of it's usefulness. GCC-3 had been out for how
> long now? I've not had any problems for a long while with 3.3.1/3.3.2,
> so unless 3.3.3 is b0rked, I think it's time to switch.
>
> But one question first... does ssp/pie work on anything besides x86? The
> reason I ask is because gcc-2.95 was left around mainly for ppc guys. If
> the toolchain will work with ppc, then we should see if ppc guys can
> build kernels w/ 3.3.3 first. If the toolchain is x86 specific, I say
> dump 2.95.3.

In the pax patch for the 2.4 kernel I see code for i386, sparc, sparc64, 
x86_64, alpha, and ppc. exec-shield only has code for i386. And I think SSP 
works on just about everything.




More information about the hlfs-dev mailing list