Report for latest propolice patch.

ashes cendres at videotron.ca
Wed Dec 31 06:09:54 PST 2003


Hello, I upgraded to the latest propolice patch from Dec 24th. I guessed the 
addition was for support for gentoo's glibc. I have new errors I would like 
to report.
FAIL: gcc.dg/uninit-C.c (test for excess errors)
FAIL: g++.dg/tls/init-2.C (test for excess errors)

Those are new as of Dec 24th, gcc-3.3.1 build without -fstack-protector. If I 
build with protectonly.dif I get these errors also.
FAIL: gcc.dg/special/gcsec-1.c (test for excess errors)
FAIL: g++.dg/tls/init-2.C
FAIL: g++.law/weak.C (test for excess errors)

Before Dec 24 I would add -fno-stack-protector to cflags for binutils make 
check and there would be no errors. Now I get these.
FAIL: bootstrap with --static
FAIL: S-records
FAIL: S-records with constructors

Are these bugs from improper installation on my part, or are they known 
propolice bugs with gcc and binutils?

Happy new year :)




More information about the hlfs-dev mailing list