[blfs-support] The dreaded "Cannot open Xorg.o.log"

Armin K. krejzi at email.com
Sat Nov 30 10:23:53 PST 2013


On 30.11.2013 18:22, Dan McGhee wrote:
> For the first time in my LFS life I got this message.  Just so people
> can roll their eyes, but also to provide info, I use the Package Users
> system.  This error, I thought, came from faulty permissions, <ls -alQ>
> gives:
>
>> -rwsr-sr-x  1 10118 10118 12630128 Nov 29 15:27 "Xorg"
>
> Where user and group 10118 are "xorg-server."
>
> I get a number of other messages when I use <startx>, but this one is
> the first message and it's the only "Fatal server error" message.  Since
> I have no log, I don't know where to begin to troubleshoot.  The only
> other obvious thing is something about which I've never thought before.
> There is a link "/usr/bin/X -->/usr/bin/Xorg" that is not suid.  The
> link is executable by all and I've never thought about the need to make
> a link suid.
>
> Anyway, I just need some suggestions on where to look for the problem.
> I installed everything in Ch. 24 of BLFS-SVN and non-root.  I've never
> encountered this situation before and am stumped.  My only goal right
> now is to get the server up and running even if nothing else works.
>
> Thanks,
> Dan
>
>
>

XServer executable *needs* to be setuid root (It's important that's also 
owned by root:root).

Also, links can't be setuid. Links have same permissions as the thing 
they are symlink to.



More information about the blfs-support mailing list