[blfs-support] LINKS in Graphic Mode

Pierre Labastie pierre.labastie at neuf.fr
Sat Nov 23 11:24:37 PST 2013


Le 23/11/2013 20:12, Dan McGhee a écrit :
> This is the first time I have ever tried to run links in graphic mode.
Hi Dan,

I have never tried that, so not sure I can help. See some basic steps below
about the group

> As user 'dan' it doesn't happen.  When I invoke 'links -g' I get the 
> error message "Can't access fb0."  As user 'root' it runs fine.
> 
> This tells me it's a permissions thing, but I don't know how to be able 
> to do it as a non-privileged user, unless links needs to be suid for 
> this.  'ls -alQ /dev/fb0' yields:
> 
> crw-rw---- 1 root video 29, 0 Nov 23 13:04 "/dev/fb0"

group is video... the numbers "29, 0" stand for the "major" and "minor" device
number.
> 
> I don't know how to interpret "video 29."  There's no such group and 
> adding myself to the video group didn't solve the situation.
You have certainly done it, but to be sure, did you logout and then login back
after adding yourself to the video group?

to make sure you are in the video group, you could type (as user dan):
groups



regards
Pierre



More information about the blfs-support mailing list