[blfs-support] Configuring GPM

Dan McGhee beesnees at grm.net
Thu Nov 21 16:53:58 PST 2013


Things have become a lot more intricate since I last did this.

I have a Synaptics Touchpad and it looks like it's supported in GPM, but 
I haven't yet been able to get it to work.  I don't know exactly what 
information to post to be helpful and may give too much.  If so, I 
apologize.

This is the way I have the mouse stuff configured in my kernel:

> CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
> CONFIG_INPUT_MOUSE=y
> CONFIG_MOUSE_PS2=m
> CONFIG_MOUSE_PS2_SYNAPTICS=y
> # CONFIG_MOUSE_SERIAL is not set
>

I didn't set MOUSE_SERIAL because mine is on the pcie bus and 'lsmod' 
indicates that "psmouse" is loaded.

I built and installed gpm with the instructions in BLFS-SVN and have 
tried four or five different options in /etc/sysconfig/mouse. Currently 
it reads:

> MDEVICE=/dev/input/mouse0
> PROTOCOL=synps2
> GMPOPTS=""
To get some info I ran 'cat /proc/bus/input/devices' and here are two 
lines of the output for the mouse:

Name "SynPS/2 Synaptic Touchpad"
Handlers mouse0 event7

Regardless of what I used for -m in 'gpm -m<device> -t -help,' nothing 
recommended synps2 which is the option for what I have.

The gpm man-page talks about /etc/syn.conf and gives many, many flags 
for operating the touchpad.  However, no documentation--that I've 
discovered thus far--indicates to install that file.  I'm not in the 
habit of just putting a configuration file in without documentation to 
support it.  But maybe I should in this case.

When I boot, the daemon starts and if I tap my pad the "rectangle" 
appears in the middle of the screen, but it won't move and I can't 
"select."  BTW I'm in a terminal and there is no X environment.

I sure would appreciate guidance.

Thanks,
Dan







More information about the blfs-support mailing list