[blfs-support] Problems Compiling Gimp, Gegl and Babl

Alan Feuerbacher alanf00 at comcast.net
Sat Nov 16 15:48:51 PST 2013


On 11/16/2013 5:07 PM, Ken Moffat wrote:
>
>   I don't have a /usr/include/babl directory or symlink.  I've now
> compiled and run a DESTDIR install of gimp-2.8.8 to be sure that
> there isn't a problem in the current version.  I had already built
> gegl-0.2.0 and babl-0.1.10.  I cannot replicate your problem.

Well, I went back and recompiled babl, gegl and gimp from scratch, using 
Bruce's suggestion of using --disable-docs to configure gegl, and 
removing the hack links in /usr/include: babl -> babl-0.1 and gegl -> 
gegl-0.2. Then everything worked. And gegl, this time, constructed a 
proper pkg-config file, "gegl-02.pc" which gimp was obviously happy 
with. I don't fully understand this.

Alan




More information about the blfs-support mailing list