[blfs-support] Problems Compiling Gimp, Gegl and Babl

Fernando de Oliveira famobr at yahoo.com.br
Sat Nov 16 05:36:56 PST 2013


Em 16-11-2013 08:51, Alan Feuerbacher escreveu:

> *===========*===========*===========*===========*===========*
> babl-0.1.10 installed without a hitch, but put all of its libraries
> and such in "babl-0.1" rather than in "babl". Gimp complained about
> that so I had to make a link:
> 
> ln -sv /usr/include/babl-0.1/babl /usr/include/babl
> *===========*===========*===========*===========*===========*

I have just installed it without problem. Perhaps, if you can install
gegl without modifications, and remove the links you added that are not
in the book would solve it. I would try fixing gegl's build and install,
first.

> *===========*===========*===========*===========*===========*
> gegl-0.2.0 would not completely compile, so I tried configuring it


> In both cases make failed with:
> ###############


> ../gegl/gegl.h
> ../tools/create-reference.rb:331:in `block (2 levels) in <main>':
> invalid byte sequence in US-ASCII (ArgumentError)
>         from ../tools/create-reference.rb:325:in `foreach'
>         from ../tools/create-reference.rb:325:in `block in <main>'
>         from ../tools/create-reference.rb:318:in `times'
>         from ../tools/create-reference.rb:318:in `<main>'
> make[3]: *** [api.html] Error 1
> make[3]: Leaving directory `/sources/gegl-0.2.0/docs'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/sources/gegl-0.2.0/docs'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/sources/gegl-0.2.0'
> make: *** [all] Error 2
> ###############

It is related to ruby.

Are you using all switches in configure as in the book, or adding
--enable-gtk-doc? Try without it.

I found a post by ĸen about this problem, perhaps it will help you:

http://permalink.gmane.org/gmane.linux.lfs.beyond.support/44766

" Have you installed ruby ?  Google has reports of that error message
with things using ruby.  Perhaps fixable by ensuring LANG and LC_ALL
are both set to en_US.UTF-8 in the environment..."

Anyway, ĸen knows much more about gelgl, babl and gimp.

-- 
[]s,
Fernando



More information about the blfs-support mailing list