[blfs-support] Glamor EGL 0.5.0 Text fix

Igor Živković contact at igor-zivkovic.from.hr
Fri Nov 15 05:33:30 PST 2013


On 2013-11-13 20:46, Igor Živković wrote:
> On 11/13/2013 06:01 PM, William Harrington wrote:
>> 
>> On Nov 13, 2013, at 10:51 AM, Igor Živković wrote:
>> 
>>> On 11/13/2013 02:26 PM, William Harrington wrote:
>>>> Greetings,
>>>> 
>>>> http://www.linuxfromscratch.org/blfs/view/svn/x/x7driver.html#glamor-egl
>>>> 
>>>> This states it is only useful if using newer AMD Radeon cards with
>>>> Xorg ATI Driver.
>>>> 
>>>> It is also useful for Intel devices as well.
>>>> 
>>>> http://www.freedesktop.org/wiki/Software/Glamor/
>>> 
>>> Thanks, fixed at revision 12210.
>> 
>> I've also soon learned from another user that Glamor EGL for intel is
>> broken and doesn't work and SNA is to be used and is default.
>> 
>> Someone needs to clear some things up so users aren't getting
>> confused. I don't use any intel video devices with Xorg, so I don' t
>> know.
>> The problem is, someone builds all the packages in Xorg thinking they
>> don' tneed glamor egl, then they end up needing it and go back and
>> have to rebuild all of the packages having glamor enabled, and then
>> realize it's broken and they should have used sna by default.
> 
> I just had to remove relevant xorg.conf part when I run into problem
> with radeon/glamor combo in the past. I'll test it with the intel card
> to see how broken is it.

I've just tested it and it works fine. It's allegedly obsoleted by SNA 
acceleration but I have yet to find official references for that. I'm 
leaving it in the book as an option.

-- 
Igor Živković
http://www.slashtime.net/



More information about the blfs-support mailing list