[blfs-support] at-spi2-core-2.10.1 build fails

Fernando de Oliveira famobr at yahoo.com.br
Sun Nov 3 11:55:35 PST 2013


Em 03-11-2013 15:49, Ken Moffat escreveu:
> On Sun, Nov 03, 2013 at 02:39:31PM -0300, Fernando de Oliveira wrote:
>> Em 03-11-2013 13:58, Bruce Dubbs escreveu:
>>> John Frankish wrote:
>>>> Ref: Beyond Linux(r) From Scratch - Version 2013-11-01, at-spi2-core-2.10.1:
>>>>
>>>> The build fails with
>>>>
>>>> CC       libatspi_la-atspi-value.lo
>>>> CCLD     libatspi.la
>>>> GISCAN   Atspi-2.0.gir
>>>
>>>> OSError: [Errno 2] No such file or directory
>>>
>>>> Is there a way to force make to provide more details as to what might be missing?
>>>
>>> Try using 'make V=1' for more verbose output.
>>>
>>>    -- Bruce
>>>
>>
>> I may be wrong, I am writing this from old memories when I had similar
>> problems again and again.
>>
>> This must be related to gobject-introspection. Is it installed?
>> Depending on the order when it was installed, other package(s) needs to
>> be reinstalled (unfortunately, I failed to remember which one(s)). if
>> somebody remembers, please help us. i think it might be just gtk+ that
>> needs to be rebuilt. Or atk, too?
>>
>  When I was testing totem for the 7.4 book, I did it on top of my
> normal desktop which includes gtk2 and gtk3 but not introspection.
> My rebuild order was : introspection, pango, atk, at-spi2-{core,atk},
> gdk-pixbuf, gtk3.	
> 
>> I never tried this solution, but there a switch that can be used in
>> configure: --enable-introspection=no or perhaps just
>> --disable-introspection. But it depends on how it is going to be used
>> and perhaps if other applications have been built with gir support.
>>
> 
>  I normally use those for gucharmap, librsvg, pygobject2, and also
> when building or rebuilding eudev.  Probably both variants work.
> 
> ĸen
> 

Thanks, ĸen,

Hope I will never forget these again. Will keep a copy in a special folder.

-- 
[]s,
Fernando



More information about the blfs-support mailing list