[blfs-support] Xorg-7.7 Does not Detect Input Devices on 64-bit Build

John Frankish j-frankish at slb.com
Sat Nov 2 00:08:11 PDT 2013


Ref: Beyond Linux From Scratch - Version 2013-11-01 Part VI. X + Window Managers

I built Xorg-7.7 in the same way on the same machine in both 32-bit and 64-bit versions.

The 32-bit version works without problems, but the 64-bit version does not seem to detect the keyboard/mouse. After issuing the "startx" command, the x-window desktop appears, but the mouse and keyboard are unresponsive and the only way out is to turn the power off.

By symlinking the Xorg.0.log to permanent storage and/or using ssh from another machine, I managed to get the Xorg.0.log (it was identical in both cases), but it doesn't appear to give many clues (see below).

Any troubleshooting pointers would be appreciated.

Regards
John

----------
64-bit

[    94.049] (EE) GLX: could not load software renderer
[    94.049] (II) GLX: no usable GL providers found for screen 0
[    94.049] (II) intel(0): switch to mode 1366x768 at 60.0 on pipe 0 using LVDS1, position (0, 0), rotation normal
[    94.056] (II) intel(0): Setting screen physical size to 361 x 203
[    94.089] (II) config/udev: Adding drm device (/dev/dri/card0)
[log stops here]

32-bit

[    18.121] (EE) GLX: could not load software renderer
[    18.121] (II) GLX: no usable GL providers found for screen 0
[    18.122] (II) intel(0): Setting screen physical size to 361 x 203
[    18.199] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    18.199] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    18.199] (II) LoadModule: "evdev"
[    18.199] (II) Loading /usr/local/lib/xorg/modules/input/evdev_drv.so
...
[much later]
[    18.231] (II) config/udev: Adding drm device (/dev/dri/card0)




More information about the blfs-support mailing list