[blfs-support] Software version

Fernando de Oliveira famobr at yahoo.com.br
Fri Nov 30 06:48:56 PST 2012


--- Em qui, 29/11/12, Ken Moffat escreveu:

> De: Ken Moffat
> Assunto: Re: [blfs-support] Software version
> Para: "BLFS Support List"
> Data: Quinta-feira, 29 de Novembro de 2012, 23:09
> 
> Thanks, will look at that too. Sorry if this top posts,
> 
> --- Em qui, 29/11/12, Bruce Dubbs escreveu:
>
>> De: Bruce Dubbs
>> Assunto: Re: [blfs-support] Software version
>> Para: "BLFS Support List"
>> Data: Quinta-feira, 29 de Novembro de 2012, 21:11
>> Fernando de Oliveira wrote:
>> > --- Em qui, 29/11/12, Ken Moffat escreveu:
>> >
>> >> De: Ken Moffat
>> >> Assunto: Re: [blfs-support] Software version
>> >> Para: "BLFS Support List"
>> >> Data: Quinta-feira, 29 de Novembro de 2012, 19:03
>> >
>> >>   Some things I could revert to
>> older gtk+-2 versions, e.g.
>> >> gvolwheel,
>> >> and I plan to replace gcalctool and evince with the
>> mate
>> >> versions
>> >> without worrying.
>> >
>> > Ken, I have used gcalctool. Many times wanted to ask
>> you:
>> >
>> > Have you ever tried "Qalculate!"?
>> >
>> > http://qalculate.sourceforge.net/
>> >
>> > It can be used as very basic calculator with its own
>> keypad, or with a
>> > click, you have a history that you can copy any part
>> of. I stop my use
>> > normally here.
>> >
>> > But it can be used in more complex ways, as scientific
>> calculator,
>> > converting units, with different basis (binary,
>> decimal, hexa, ...,
>> > currencies, variables, functions, RPN, many other
>> possibilities.
>> 
>> I've been using galculator
>> 
>> http://galculator.sourceforge.net/
>> 
>> Uses gtk+-2 and looks like a HP calculator.  I'm using
>> version 1.3.4, 
>> but current is 2.0.
>> 
>> ./configure --prefix=/usr &&
>> make LIBS=-lm         
>>    &&
>> sudo make install

ISTR having tryied both, before deciding, but cannot remeber why I
decided for Qalculate! (GTK+). There is also a KDE version with Qt.
Works well for me.

However, looking below (after signature)for the dependencies, galculator
seems to be a better choice.

Just for the records, I used:

./configure                  \
            --prefix=/usr    \
            --disable-static \
            --enable-shared
(cannot remember if this was after searchin in the possibible switches
or "just in case")
make
make install


[]s,
Fernando

http://qalculate.sourceforge.net/downloads.html

<<
... libqalculate is required for all the other packages.
Qalculate version 0.9.7 (2010-01-06)

    libqalculate
    Qalculate! (GTK+)
    Qalculate! (KDE)

If qalculate-gtk or qalculate-kde is installed, the units, currency and bases packages do not add any additional functionality, only three small separate utilities tailored for specific usage.

    Qalculate! Units
    Qalculate! Currency
    Qalculate! Bases

[...]

Library requirements:

    CLN - Class Library for Numbers
    Libxml2 (>= 2.3.8)
    Glib 2.x
    Gnuplot 1.7 (optional, for plotting)
    GNU Wget or gnome-vfs (optional, for retrieval of exchange rates, not needed if you use the KDE GUI)

KDE GUI requirements:

    kdelibs 3.x
    Qt >= 3.1

GTK+ GUI requirements:

    GTK+ 2.4
    Libglade 2.0
    ScrollKeeper
    Yelp and libgnome-2.0 (optional, for the manual)

Text interface requirements:

    GNU Readline

Qalculate! Bases, Currency, and Units requirements:

    GTK+ 2.4
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20121130/c28c50cc/attachment.html>


More information about the blfs-support mailing list