[blfs-support] gtk+2 in the book : Makefiles renders as MakefileS for me.

Bruce Dubbs bruce.dubbs at gmail.com
Wed Nov 28 15:19:27 PST 2012


Ken Moffat wrote:
>   I was originally going to post this to -dev, but since I don't have
> a clue what is wrong I guess -support might get more response.
>
>   I'm updating some of my scripts, and I got to gtk+-2.  I see that
> we still run the seds because of the bugs in the Makefiles, but in
> firefox-17.0, at least on *this* machine (running ff-17.0), the
> explanation renders as 'MakefileS' for both occurrences (in my local
> copy and the online version).  So, I went to correct that, but the
> xml correctly says:
>
>        This <command>sed</command> fixes the
>        <filename>Makefile</filename>s.
>
>   Weirdly, when I *paste* from firefox to show how I can read it, the
> pasted text is correct:
>
> If you have DocBook-utils-0.6.14 installed (specifically, if
> configure finds db2html) then it will try to use it to rebuild some
> of its HTML documentation and fail due to bugs in some of the
> Makefiles. This sed fixes the Makefiles.

That's weird.  I am using seamonkey-2.10.1 and do not have the problem. 
I suspect that it is a LANG problem, but I don't use any LANG setting.

Take a look at the html code.  I have  <code 
class="filename">Makefile</code>s in two places.

The css could be an issue because 'code' asks for 'font-family: monospace;'

>   Anyone else see anything like this anywhere ?  I'm guessing it
> might be a problem in fontconfig or cairo (and yes, I know system
> cairo is not supported by the firefox devs).  If it's just my
> machines (or my eyes deciding to play weird) I can live with it.

>   I'm running cairo-1.12.2 with the patch, and fontconfig-2.10.1,
> also LibreOffice-core-3.6.3.2.  I mention that because fontconfig
> complains on stderr when I run writer -

I am running cairo-1.12.2, fontconfig-2.9.0, libreoffice-core-3.5.4.2.

> Fontconfig warning:
> "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13:
> Having multiple <family> in <alias> isn't supported and may not
> works as expected

When I run writer from the command line, it comes up and when I exit, 
there is no output to terminal so that's normal.  I do have the multiple 
<family> entries in the fc_local.conf file, but that seems to be ignored 
with the older fontconfig.

   -- Bruce




More information about the blfs-support mailing list