[blfs-support] Problems installing libdrm and mesa in /usr

Bruce Dubbs bruce.dubbs at gmail.com
Sat Nov 17 09:39:46 PST 2012


Ragnar Thomsen wrote:
> I tried installing libdrm and mesa in /usr as BLFS does it now. However, I run
> into a problem. Libdrm installs without problems, but when building mesa I get
> the following error:
>
> make[4]: Entering directory
> `/sources/xc/Mesa-9.0.1/src/gallium/auxiliary/pipe-loader'
>    CC       pipe_loader_drm.lo
> pipe_loader_drm.c:40:22: fatal error: xcb/dri2.h: No such file or directory
> compilation terminated.
>
> I checked that the dri2.h file is installed in /usr/X11/include/xcb and the
> right paths are set in the xcb-dri2.pc file.
>
> Any ideas?

I don't know about a 'proper' fix, but you can use:

export C_INCLUDE_PATH=/usr/X11/include/xcb

for a workaround.

On my system, I have two instances of dri2.h:

31952 -rw-r--r-- 1 58809 Sep 10 03:23 /opt/xorg/include/xcb/dri2.h
31952 -rw-r--r-- 1 58809 Sep 10 03:23 /opt/xorg/include/xcb/dri2.h

Note that they have the same inode so are hard links.


   -- Bruce



More information about the blfs-support mailing list