[blfs-support] Problems installing libdrm and mesa in /usr

Ken Moffat zarniwhoop at ntlworld.com
Sat Nov 17 08:59:08 PST 2012


On Sat, Nov 17, 2012 at 05:30:54PM +0100, Ragnar Thomsen wrote:
> I tried installing libdrm and mesa in /usr as BLFS does it now. However, I run 
> into a problem. Libdrm installs without problems, but when building mesa I get 
> the following error:
> 
> make[4]: Entering directory 
> `/sources/xc/Mesa-9.0.1/src/gallium/auxiliary/pipe-loader'
>   CC       pipe_loader_drm.lo
> pipe_loader_drm.c:40:22: fatal error: xcb/dri2.h: No such file or directory
> compilation terminated.
> 
> I checked that the dri2.h file is installed in /usr/X11/include/xcb and the 
> right paths are set in the xcb-dri2.pc file.
> 
> Any ideas?
> 
> -Ragnar-

 For fixing it, no : Mesa used to be sufficiently different from
regular configure scripts that I wouldn't know where to begin.

 My first suggestion was going to be to try to work around it, with
a symlink from /usr/include/xcb to /usr/X11/include/xcb. But that
might mean adding other symlinks, and finding a way to point it to
the libs so it could link.

 In 8.0.4, which is the latest version I have here, configure's help
includes the following, which may or may not be accurate (I've had
"issues" with past versions ;-) :

X features:
  --x-includes=DIR    X include files are in DIR
  --x-libraries=DIR   X library files are in DIR
These options are only used when the X libraries cannot be found by the
pkg-config utility.

 So, I recommend you look for something like that in the current
version.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list