[blfs-support] building sawfish-1.9.1

Jim Michmerhuizen jamzen at michmer.net
Mon Nov 12 13:27:25 PST 2012


On 11/12/2012 02:31 PM, Armin K. wrote:
> On 11/12/2012 08:12 PM, Jim Michmerhuizen wrote:
>> ...generated this error:
[snip]
>> fonts.o: In function `pango_draw_line':
>> /xc/sawfish-1.9.1/src/fonts.c:519: undefined reference to `pango_x_render'
>> collect2: error: ld returned 1 exit status
>> make[1]: *** [sawfish] Error 1
>> make[1]: Leaving directory `/xc/sawfish-1.9.1/src'
>> make: *** [all] Error 1

>>
>> Has anybody encountered this problem and solved it?
>>
>
> Interesting. That might be the problem with pango 1.32. Pango 1.32 has
> pangox library removed. There is however pangox compat library, but I
> didn't include it in BLFS since nothing was using it back then.
>
> Try downloading this package:
>
> http://ftp.acc.umu.se/pub/gnome/sources/pangox-compat/0.0/pangox-compat-0.0.2.tar.xz
>
> Build it with ./configure --prefix=/usr --sysconfdir=/etc
> --disable-static && make && make install
>
> Then restart sawfish build process and please report if that worked.
>
Yeah, that got me built.  I have a runtime problem -- nothing works -- 
but the build succeeded.  Thanks for the quick response.

("Nothing works"), i.e. black display, no mouse or keyboard interaction. 
  But I'm pretty certain that's entirely distinct from this pango thing.

So far, of the four window managers, *fluxbox* and *icewm* work for me, 
*openbox* starts with a black screen but responds to mouse and keyboard, 
and *sawfish* remains dormant.  I'm trying to formulate some sensible 
questions about the whole situation.

Any advice about this flailing around will be welcome.


-- 
Regards
             Jim Michmerhuizen        http://michmer.net
"Actions speak louder than words ... but not as clearly"



More information about the blfs-support mailing list