[blfs-support] black screen and cursor after installing gdm in blfs

Armin K. krejzi at email.com
Mon Nov 5 21:20:53 PST 2012


On 11/06/2012 06:03 AM, James Pinto wrote:
>
> Hi
>
> I have attached the gdm logs. And heres the mediafire link to them also:-
>
> http://www.mediafire.com/?e5ls3r420obnhf6,ja8trab1o7rxc9c
>
> Also heres the  output of the groups command from a *normal user*:-
> #  groups
> james video
>   As root I get the the word 'root' as ouput for the command groups.
>
> I have also installed openssh and gtk-engines
>
> I tried startx after logging into the normal user '*james*' but I only
> the the 4 xterm windows instead of going into gnome 3.
>
> Also the output of glxinfo as a *normal user* says Error:unable to open
> graphics.
>
> But as *root *the output of glxinfo is :-
> http://pastebin.com/94kA84ey
>
> Regards
> --

Wow, that's new one.

I noticed few things. .xsession-errors still shows same output about 
gtk-engines and ssh-agent (not very important).

This might be a culprit for gdm failure:

_IceTransSocketUNIXConnect: Cannot connect to non-local host phoenixfusion

your "hostname" should resolve to local address (192.168.x.x, 10.10.x.x 
or 127.0.1.1)

What does "cat /etc/hosts" say?

I recommend you add your user to group "audio" as described on 
alsa-utils page (not related, but can help you to avoid further problems).

Also, you should add user "gdm" to "audio" and "video" groups as 
described on gdm page (if not done already).

Regarding glxinfo and permission denied, that is the problem why shell 
isn't starting. Please run this as normal user and post the whole output

LIBGL_DEBUG=verbose glxinfo

And at last, does /lib/udev/udev-acl exist? (ls -ld /lib/udev/udev-acl)



More information about the blfs-support mailing list