[blfs-support] fatal error: goo/gmem.h: No such file or, directory; but file does exist!!; cups-filters

Leon Goldman leon244 at comcast.net
Mon Nov 5 05:32:09 PST 2012


I may not be responding correctly so my responses don't end up in the 
correct thread -- if so, I apologize

 > When you installed poppler, you should have created
 > /usr/lib/pkgconfig/poppler.pc.  Check to see if that is present.

Actually /usr/lib/pkgconfig/poppler.pc does exist. However, I am using a 
x86_64 system and have a /usr/lib64/pkgconfig also. When I built poppler 
and libqpdf I just used teh defaults. In /usr/lib64/pkgconfig there is a 
poppler.pc file which lists the version as 0.16. The poppler.pc in 
/usr/lib lists the version as 0.20.5.   Should I uninstall and recompile 
poppler and libqpdf with LIBDIR=/usr/lib64?

Would the correct steps be to first do a make uninstall for poppler and 
libqpf, then remove the directories created when the tarball was 
extracted, re-extract the archive, then proceed with ./configure 
--LIBDIR=/usr/lib64  and then try to recompile cups-filters?

Thanks
-- 
Leon



More information about the blfs-support mailing list