[blfs-support] errors building libpng

Jim Michmerhuizen jamzen at michmer.net
Sun Nov 4 16:12:14 PST 2012


rain, pour, pot kettle black etc.

Am I being oversensitive?  Building libpng-1.5.13 generated this 
sequence of warnings and a final error message:

========================================== BEGIN QUOTED BUILD OUTPUT
...snip...
gawk -f ./scripts/checksym.awk ./scripts/symbols.def\
     scripts/symbols.out >&2
png.h: exported symbol 235 'png_get_acTL' not present in 
./scripts/symbols.def
png.h: exported symbol 236 'png_set_acTL' not present in 
./scripts/symbols.def
png.h: exported symbol 237 'png_get_num_frames' not present in 
./scripts/symbols.def
png.h: exported symbol 238 'png_get_num_plays' not present in 
./scripts/symbols.def
png.h: exported symbol 239 'png_get_next_frame_fcTL' not present in 
./scripts/symbols.def
png.h: exported symbol 240 'png_set_next_frame_fcTL' not present in 
./scripts/symbols.def
png.h: exported symbol 241 'png_get_next_frame_width' not present in 
./scripts/symbols.def
png.h: exported symbol 242 'png_get_next_frame_height' not present in 
./scripts/symbols.def
png.h: exported symbol 243 'png_get_next_frame_x_offset' not present in 
./scripts/symbols.def
png.h: exported symbol 244 'png_get_next_frame_y_offset' not present in 
./scripts/symbols.def
png.h: exported symbol 245 'png_get_next_frame_delay_num' not present in 
./scripts/symbols.def
png.h: exported symbol 246 'png_get_next_frame_delay_den' not present in 
./scripts/symbols.def
png.h: exported symbol 247 'png_get_next_frame_dispose_op' not present 
in ./scripts/symbols.def
png.h: exported symbol 248 'png_get_next_frame_blend_op' not present in 
./scripts/symbols.def
png.h: exported symbol 249 'png_get_first_frame_is_hidden' not present 
in ./scripts/symbols.def
png.h: exported symbol 250 'png_set_first_frame_is_hidden' not present 
in ./scripts/symbols.def
png.h: exported symbol 251 'png_read_frame_head' not present in 
./scripts/symbols.def
png.h: exported symbol 252 'png_set_progressive_frame_fn' not present in 
./scripts/symbols.def
png.h: exported symbol 253 'png_write_frame_head' not present in 
./scripts/symbols.def
png.h: exported symbol 254 'png_write_frame_tail' not present in 
./scripts/symbols.def
*** A new list is in symbols.new ***
make: *** [scripts/symbols.chk] Error 1
============================================ END QUOTED BUILD OUTPUT

I've looked at the awk script that generated this, and it all seems 
pretty innocent, but can anybody confirm that it really is?

In the meantime I'm continuing the build.

-- 
Regards
             Jim Michmerhuizen        http://michmer.net
"Actions speak louder than words ... but not as clearly"



More information about the blfs-support mailing list