[blfs-support] fatal error: goo/gmem.h: No such file or directory; but file does exist!!; cups-filters

Bruce Dubbs bruce.dubbs at gmail.com
Sun Nov 4 08:18:50 PST 2012


Leon Goldman wrote:
> First, I thank you all for your book and the work that has been done on
> it. That's a lot of work.
>
>    I am actually using Mandriva 2011, but wanted to upgrade CUPS to 1.6.1
> so used your book to help me. I built 1.6.1 and then tried to build
> cups-filters. I did not have poppler > 0.20 so downloaded it and built
> it. I then tried to make cups-filters.
>
> The first error I got was that pkg-config said I did not have poppler >=
> 0.18 and so I entered the path into POPPLER_LIBS and POPPLER_CFLAGS. I
> also had to do that for LIBQPDF which I did.
>
> But when I ran make from the cups-filters directory I got the message:
> fatal error: goo/gmem.h: No such file or directory; but file does exist!!
>
> I did a locate on my system and it showed that the files exist:
> /usr/include/glib-2.0/glib/gmem.h
> /usr/include/poppler/goo/gmem.h
> /usr/include/xpdf/goo/gmem.h
>
> I then entered /usr/include/poppler into my LD_LIBRARY_PATH and still
> got the error after doing a make clean and rerunning ./configure and
> then make.
>
> I am hoping I might get guidance from you. I can find nothing on the web
> that helps and no answers from other fora or from CUPS

When you installed poppler, you should have created 
/usr/lib/pkgconfig/poppler.pc.  Check to see if that is present.

I have no idea what LIBQPDF is.

LD_LIBRARY_PATH is for specifying library paths for running programs.  I 
suspect you want LIBRARY_PATH for gcc to find included files.

It would help to see the error, but not too much before of after the 
error.  Just the line that actually generates the error and it's output 
would be fine.

   -- Bruce





More information about the blfs-support mailing list