[blfs-support] gnome not working

Ken Moffat zarniwhoop at ntlworld.com
Thu Nov 1 15:52:23 PDT 2012


On Thu, Nov 01, 2012 at 03:18:14PM -0500, zhongcai zhou wrote:
> I did compile and install  AccountsService-0.6.25. I found
> accounts-daemon did not run automatically.
> So I started it manually with accounts-daemon command. But it did not
> help and produced the same error.
> 
 Please note that I haven't tried to use most of gnome since
gnome-3.2, so this might now be out of date.  But, in those days my
commands in .xinitrc for full gnome [1] were:

exec ck-launch-session dbus-launch --exit-with-session gnome-session

 I don't know what the current book recommends (I'm using ssh to my
server, don't have a browser handy), but if it is different, maybe
you could try this ?

 In theory, gnome-session will launch everything it needs, provided
that console-kit and dbus are running : I suspect the console-kit
part might have changed since 3.2, but I'm afraid I'm not paying
attention to the details of what I don't use.

 If that didn't help, are you building *everything* with a prefix of
/usr ?  Trying to get other prefixes to work with gnome (and xorg)
has often caused problems.

ĸen

1.  I also had variants for my normal window manager, and to force
gnome-shell on hardware which appeared not to support it and
defaulted to metacity : I say 'appeared' because it eventually
turned out that even my old radeon was good enough if I was in the
video group.
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list