[blfs-support] Read ntfs file system

Ken Moffat zarniwhoop at ntlworld.com
Mon Feb 27 14:13:54 PST 2012


On Mon, Feb 27, 2012 at 04:58:53PM +0000, spiky wrote:
> Hi
> 
> I have stared another Blfs 7.0 build and I,m having trouble with NTFS 
> file system, I have built the 3.3 kernel marking all ntfs boxes. The 
> build for blfs doesn't have anything installed except ssl, ssh a few 
> graphics libraries. What  do I need to add to be able to read ntfs, My 
> other blfs system reads ntfs but I have installed alot of other 
> software, so maybe it was something that I had already installed, my 
> other blfs uses 3.2 kernel FYI
> 
> Thks.
 Note that 3.3 is still an -rc, so it's possible that there is
something broken in the version you built.  If so, you could use
'git bisect' to find which commit broke it.  Fun, or not,
depending partly on your definition of fun, and partly on whose
commit turns out to be the problem.

 But first: you imply this is the only kernel on this system ?
Build 3.2.latest using your earlier 3.2 config (if you have one for
this machine).  If *that* fails, and you know the config was good,
go back to whichever previous 3.2 version worked.  If the config
turns out to be bad, rinse and repeat.  You then have a known-good
version.  Actually, if you intend to bisect, you need to go back to
3.2 itself because the 3.2.x stable releases aren't ancestors of 3.3.

 After that, try the latest 3.3 tree - either the latest -rc, or
linus's latest tree.  Make sure you take your known good config,
copy it to .config, make oldconfig, then see if it works.  If it
does, all is good - either you had a config error, or someone else
has already fixed the problem.

 If it still doesn't work, and you are willing to bisect, you then
need to install git, get the kernel sources, and run git bisect.
After several, or many, rebuilds you will have a commit to blame.
You can then try reverting just that commit - sometimes, that proves
the problem is there, other times it doesn't compile/run,
occasionally it still doesn't work (i.e. a mistake in bisection - if
so, repeat).  Then you need to report the problem to lkml (CC
whoever wrote the commit), and wait to be flamed, or offered
suggestions, or asked for further information.  Flames usually
relate to asking about tainted kernels (proprietary modules, or
perhaps vmware).

 Alternatively, you could hope the problem (if it still exists) will
get fixed before the 3.3 release.  Personally, I suspect your
.config is missing something (probably unrelated to ntfs),

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list