[blfs-support] Make 3.82 Dev86src triple bug fixes patch

Ken Moffat zarniwhoop at ntlworld.com
Thu Feb 16 15:42:01 PST 2012


On Thu, Feb 16, 2012 at 11:25:53PM +0000, Ken Moffat wrote:
>  I no longer have any lilo systems, nor any x86_64 using make-3.81,
> but bin86-0.16.17 [ I assume it has been renamed ] used to work if
> it had a patch applied (I've still got the patch lying around -
> and it looks like it was in LFS-patches as well as clfs).  The patch
> defines 'Long' (as int) for x86_64.  Just a straight 'make' and
> 'make install'.   If the package has a different name, perhaps it
> now builds other things.  Dunno.
> 
 Yeah, sounds like a problem with the repackaged version.  With
bin86-0.16.17 from http://homepage.ntlworld.com/robert.debath/ and
the patch from
http://www.linuxfromscratch.org/patches/downloads/bin86/ I can
'make' on x86_64 with make-3.82.  Unless a newer version of lilo
needs something beyond as86, as86_encap, chk, catimage, ld86,
objchop, objdump86 then I recommend using the 'original' package.

 Alternatively, perhaps there is some way to only build the required
part of the repackaged version.

 I can't say that I care particularly - I had to give up my old lilo
when my drive changed from hda to sda with a kernel change, and it
refused to accept that root=/dev/sdaX could be a valid commandline
option if /dev/sdaX didn't exist at the time I ran lilo.  Grub2 is
no better nor worse, just different, and it brings its own issues -
but that is the nature of bootloaders.

ĸen (used to be the 'x86_64-64 guy')
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list