[blfs-support] pcre-8.30

Markku Pesonen tourula at gmail.com
Sun Feb 12 16:11:40 PST 2012


Bruce Dubbs wrote:
> Hmm.  I think this is a big problem with libpcre.  If they are going to 
> break the interface, then they need to change the library to 
> libpcre.so.2.  When you replace a library, you are not supposed to need 
> to change anything in applications that use the library.

They did change it. Version 8.21 has libpcre.so.0.0.1 and 8.30 has
libpcre.so.1.0.0. When upgrading a working system, you should always
keep the old version of a library installed, until all programs that
depend on it are recompiled against the new one.




More information about the blfs-support mailing list