[blfs-support] pcre-8.30

Bruce Dubbs bruce.dubbs at gmail.com
Sun Feb 12 14:11:07 PST 2012


Ken Moffat wrote:
>
>  With respect, it's grep.  The change to libpcre.so.1 has apparently
> broken booting for those who upgrade existing systems without
> recompiling grep.  I thought LFS used to have a warning about this,
> but all I can see is the comment on --disable-perlregexp in (7.0)
> chapter 5.

Hmm.  I think this is a big problem with libpcre.  If they are going to 
break the interface, then they need to change the library to 
libpcre.so.2.  When you replace a library, you are not supposed to need 
to change anything in applications that use the library.

   -- Bruce



More information about the blfs-support mailing list