[blfs-support] pcre-8.30

Ken Moffat zarniwhoop at ntlworld.com
Sun Feb 12 13:35:12 PST 2012


On Sun, Feb 12, 2012 at 02:09:49PM -0600, Bruce Dubbs wrote:
> Fernando de Oliveira wrote:
> > LFS 6.5, 6.7, 6.8 and SVN-20111210.
> > 
> > Building pcre-8.30 was a little difficult.
> > 
> > First attempt, grep stopped working, with message:
> > 
> > "grep: error while loading shared libraries: libpcre.so.0: cannot
> > open shared object file: No such file or directory".
> 
> What program is using libpcre?
> 
> I always recommend booting to level 3 and using startx and not ?dm for 
> exactly this type of problem.
> 
>    -- Bruce

 With respect, it's grep.  The change to libpcre.so.1 has apparently
broken booting for those who upgrade existing systems without
recompiling grep.  I thought LFS used to have a warning about this,
but all I can see is the comment on --disable-perlregexp in (7.0)
chapter 5.

 The LFS bootscripts use grep in the cleanfs and console scripts,
so runlevel 3 is apparently broken.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list