Csound5.12.1 on 64-bit amd64cpu setup

lI lux-integ at btconnect.com
Wed Jun 23 10:22:26 PDT 2010


On Wednesday 23 June 2010 15:25:12 Aleksandar Kuktin wrote:

> > I tried changing  <cmath> to <math.h> in InOut/widglobals.h  with the
> > same result   except for the reference
> > to /usr/lib/gcc/x86_64-unknown-linux-
> > gnu/4.4.2/../../../../...etc              in the compiler output.
> >
> > Advice/help would be appreciated
> >
> > sincerely
> > lux-integ
> 
> Hello,
> 
> >From what I can see in here, the breakage is somewhere in coordinating
> 
> the headers. I will now assume that your cmath header
> in /usr/include/c++/4.4.2 is normally working (this ofcourse may not
> necessarily be the case, but if you successfully built BLFS, then it
> by itself probably works).
> I have just double-checked on my system (CBLFS with GCC-4.4.3), and
> what may (or may not) be the likely source of trouble is the math.h
> header. The one you need is /usr/include/math.h . With all those -I
> flags up there, could it be that another math.h (or a different cmath
> for that matter?) is being preloaded??
> `gcc -M' should help you pinpoint all the headers that are being
> included (do not forget to remove the -o what/ever.o flag).
> 
> -AKuktin

there is only one math.h in and its in  /user/include and as I said above  
(bottome of large posting)  I   tried using it in InOut/widglobals.h  instead 
of cmath  (in /usr/include/c++/4.4.2 )  with more or less the same result. 

Now to short-circuit things,  Could you let me know if you have built 
Csound5.12.1 (or equivalent) on a pure 64bit clfs setup and if so could you 
let me have your recipe?



More information about the blfs-support mailing list