MySQL and "More Control/Package Users" Package Mgmt

Mike McCarty Mike.McCarty at sbcglobal.net
Wed Jun 23 04:04:15 PDT 2010


Timothy Rice wrote:
> Hey Chris (and everyone else as well),
> 
>> /usr/share/info ~/mysql-5.1.42
>> rm: remove write-protected regular file `dir'?
>>
>> It is trying to update /usr/share/info/dir. My solution was to make
>> /usr/share/info/dir owned by the "install" group and group writable.
> 
> I tried doing this. However, an error still resulted. I therefore tried
> chmodding each of the three files called 'dir' to have permissions 777. I
> still get the following error:
> 
> \begin{output}
> make[1]: Leaving directory `/usr/local/src/mysql-5.1.42/mysql-5.1.42/win'
> /usr/lib ~/mysql-5.1.42
> `./libmysqlclient.so*' -> `mysql/libmysqlclient.so*'
> `./libmysqlclient_r.so*' -> `mysql/libmysqlclient_r.so*'
> ~/mysql-5.1.42
> /usr/share/info ~/mysql-5.1.42
> rm: cannot remove `dir': Operation not permitted
> \end{output}
> 
> Which seems really weird. So, any more ideas on what could be going wrong?

Perhaps during the make the directory gets destroyed/created.

> The only thing I can think of is that although /usr/share/info/dir now
> belongs to the install group, it is still owned by the root user. But with

Maybe not. Maybe the file you have _now_ is not the file you modified.

> 777 permissions on it, that shouldn't be a problem, should it?

I'd let the make get up to the point where it prompts, and then
go look at the permissions.

Mike
-- 
p="p=%c%s%c;main(){printf(p,34,p,34);}";main(){printf(p,34,p,34);}
Oppose globalization and One World Governments like the UN.
This message made from 100% recycled bits.
You have found the bank of Larn.
I speak only for myself, and I am unanimous in that!



More information about the blfs-support mailing list