MySQL and "More Control/Package Users" Package Mgmt

Timothy Rice t.rice at ms.unimelb.edu.au
Wed Jun 23 00:52:08 PDT 2010


Hey Chris (and everyone else as well),

> /usr/share/info ~/mysql-5.1.42
> rm: remove write-protected regular file `dir'?
>
> It is trying to update /usr/share/info/dir. My solution was to make
> /usr/share/info/dir owned by the "install" group and group writable.

I tried doing this. However, an error still resulted. I therefore tried
chmodding each of the three files called 'dir' to have permissions 777. I
still get the following error:

\begin{output}
make[1]: Leaving directory `/usr/local/src/mysql-5.1.42/mysql-5.1.42/win'
/usr/lib ~/mysql-5.1.42
`./libmysqlclient.so*' -> `mysql/libmysqlclient.so*'
`./libmysqlclient_r.so*' -> `mysql/libmysqlclient_r.so*'
~/mysql-5.1.42
/usr/share/info ~/mysql-5.1.42
rm: cannot remove `dir': Operation not permitted
\end{output}

Which seems really weird. So, any more ideas on what could be going wrong?
The only thing I can think of is that although /usr/share/info/dir now
belongs to the install group, it is still owned by the root user. But with
777 permissions on it, that shouldn't be a problem, should it?

Cheers,

Tim



More information about the blfs-support mailing list