can't get cdrom to mount

akhiezer lfs65 at cruziero.com
Thu Jun 10 08:31:24 PDT 2010


> From blfs-support-bounces at linuxfromscratch.org Sun Jun  6 18:52:16 2010
> Date: Sun, 06 Jun 2010 12:51:04 -0500
> From: Carl <c.thorn at sbcglobal.net>
> To: BLFS Support List <blfs-support at linuxfromscratch.org>
> Subject: can't get cdrom to mount
>
> Hi
> I have successfully built beyond linuxfromscratch to an almost full 
> function desktop based on the lfs version 6.6 using the blfs svn 
> version. I have a working word processor(abiword) a working 
> spreadsheet(gnumeric) and have added audacious audio player. Audacious 
> will read and play my audio cds. but gnome desktop will not mount the 
> cdrom. I get the following error message on bootup.
> [49358.956254] hdc: command error: status=0x51 { DriveReady SeekComplete 
> Error }
> [49358.956278] hdc: command error: error=0x54 { AbortedCommand 
> LastFailedSense=0x05 }
> [49358.956288] hdc: possibly failed opcode: 0xa0
> [49358.960145] end_request: I/O error, dev hdc, sector 1272680
> [49358.960178] __ratelimit: 1 callbacks suppressed
> [49358.960187] Buffer I/O error on device hdc, logical block 159085
> [49358.976083] hdc: command error: status=0x51 { DriveReady SeekComplete 
> Error }
> [49358.976107] hdc: command error: error=0x54 { AbortedCommand 
> LastFailedSense=0x05 }
> and it repeats multiple times. I believe the error message comes from hal.
> I have tried recompiling my kernel but I think everything is right there 
> and I have messed with fstab but am not sure I have that right. I don't 
> think there is anything wrong with the hardware as I have Ubuntu 
> installed on a different partition on the same machince and it mounts 
> the drive with no problem. I am open to any suggestions as to where to 
> look for a solution.
> -- 
	.
	.
>


Those errors may be appearing if/because you're trying - directly or 
indirectly, via fstab or elsewhere - to explictly mount an audio cd: 
whereas of course there's no filesystem on an audio cd for mount to 
work with - it's an old chestnut.

I've just now double-checked and verified this on an old-ish machine 
(p4 2.4ghz, ide) running slackware-13.0 (uses 2.6.29.x kernel, and 
'hda/hdb/hdc/...' device naming), and using Xfce as Desktop Environment: 
put an audio CD into cd/dvd drive (here, it's /dev/hdc aka /dev/cdrom), 
do 'mount /dev/cdrom /mnt/tmp' (or similar) on command-line, and ... 
hey presto, almost exactly the same set of error messages as you list, 
show up here in /var/log/syslog .

As for how to _stop_ the errors on your setup: I don't really know in 
enough detail, how to tell HAL/whatever to handle/detect audio cd -vs- 
data cd, or even if they need/want to; but, hopefully the info that you 
typically can't mount audio cd in the same way as data cd, will be of 
help.


akhiezer





--



More information about the blfs-support mailing list