Mesa-7.6+ and radeon [was Re: comments on BLFS development version and beyond]

Andrew Benton b3nton at gmail.com
Wed Feb 24 16:31:33 PST 2010


On 24/02/10 22:40, Ken Moffat wrote:
> On 24 January 2010 02:32, Ken Moffat<zarniwhoop73 at googlemail.com>  wrote:
>> 2010/1/23 Ken Koehler<koehlekr at ucrwcu.rwc.uc.edu>:
>
>
>>> 11) I installed xscreensaver 5.10, and ended up (as before) setting it
>>> to just blank the screen because in a matter of minutes to hours it
>>> locked my system up tight (wouldn't even respond to Alt-SysRq)
>>>
>>   At the moment, I'm trying to bisect mesa (again), to try
>> to discover what broke glxgears on my radeon r200 [ first
>> attempt in the 'stable' releases foundered on a merge,
>> looks as if they maintain the stable releases in CVS and
>> backport versions to the main git tree ].  I only looked at
>> that because xscreensaver-5.10 was locking up my
>> machine.
>>
>   I've now got a result, after showing my general ignorance in
> https://bugs.freedesktop.org/show_bug.cgi?id=26051 - people
> using current Mesa will see a fix in
> 3f5bac8960a5c6d1f08f0dc849676139b9d6ce5c.
>
>   Looks as if BLFS-6.5 is going to stick with Mesa-7.6, so
> I'll attach my version (the last hunk of upstream's change
> deletes an invocation of radeonEmitState in radeon_ioctl.c
> which isn't present in 7.6.1) - tested with 7.6.1, applies to
> 7.6 but I haven't looked at or tested 7.6.
>
>   Makes me think nobody else here uses radeon!

I have Radeon cards on 2 computers, both r600 series. I couldn't get mesa 7.6 to
work at all. 7.5.2 worked OK but Mesa 7.7 is excellent. I didn't comment on your
problem because I don't install xscreensaver.

I did have a problem with opengl apps locking up xorg hard, but it turned out it
was a bug in the radeon driver that was related to the amount of memory on the
video card. The patch is here http://bugs.freedesktop.org/attachment.cgi?id=30130
the bug is here http://bugs.freedesktop.org/show_bug.cgi?id=24301

Andy



More information about the blfs-support mailing list