why gcc must be built two times?

Ken Moffat zarniwhoop73 at googlemail.com
Tue Feb 23 06:52:58 PST 2010


On 23 February 2010 14:04, Marco Marzetta <aristarcoarchetipo at yahoo.it> wrote:
>
> Hi, I finished building LFS. Now looking through the manual I find BLFS to section 6.3 to install GCC version 4.1.2, but in reality GCC is already installed with LFS in paragraph 6.15 and in a version 4.4.1. Why should I install twice the same package?! What is this mess?!
>
 "This mess" is a collection of many things that you *might*
want to do on your new system.  Nobody, except perhaps
somebody testing the book, should attempt to do all of it.
For example, some parts (e.g. mailservers) are alternatives.

 The gcc page is only for people who wish to build other
languages than c,c++.  You seem to be using LFS-6.5, so
you *really* need to follow the development version of
BLFS - when I last looked, that had been updated for
gcc-4.4.1.

ĸen
--
After tragedy, and farce, "OMG poneys!"



More information about the blfs-support mailing list