bug in netstat (net-tools-1.60)

Ken Moffat zarniwhoop73 at googlemail.com
Sat Feb 20 16:00:26 PST 2010


On 20 February 2010 21:42, Scott Kopel <skopel at fsu.edu> wrote:
> I've been using lfs/blfs on 2 production web servers for about 10 years so thank you for that
>
> this is my third build lfs/blfs and it went very well and all is running smoothly except there is a bug in net-tools-1.60 which shows up in the later kernels (I'm using kernel 2.6.30.10)
>
> aparently netstat -s has trouble with /proc/net/snmp following is the error message
>
> "error parsing /proc/net/snmp: Success"
>
> the problem is well described here:
> https://bugzilla.redhat.com/show_bug.cgi?id=131539
> and apparently redhat has made a patch in their net-tools rpm
>
> I was hoping blfs could make a patch for this?
> I've looked all over and can't find a patch that patches the source
> thanks a bunch
> s
>
 Look at fedora cvs
[ http://cvs.fedoraproject.org/viewvc//rpms/ ]

Looking at net-tools.spec, seems to be revision
1.25 which added net-tools-1.60-parse.patch.

 I'm in epiphany at the moment (waiting for my
firefox rebuild to complete) and it doesn't seem
to want to download the patch, but try this link -

http://cvs.fedoraproject.org/viewvc/rpms/net-tools/F-13/net-tools-1.60-parse.patch?revision=1.1&content-type=text%2Fplain&view=co

On the face of it, the package is supposed to
only need the patches in the development
version of blfs for LFS-6.5, but maybe 'netstat -s'
wasn't tested. or maybe the kernel headers
were changed again before the version in
LFS-6.5

ĸen
-- 
After tragedy, and farce, "OMG poneys!"



More information about the blfs-support mailing list