Problem with the greek fonts after returning back from X to the linux console

Agathoklis D. Hatzimanikas a.hatzim at gmail.com
Mon Feb 15 00:16:35 PST 2010


Hi Nikos,

On Sun, Feb 14, at 09:39 nikos wrote:
> Hi!
> 
> My problem is that when i login, greek fonts works perfect on the
> console, 
> also again in xorg,but stops working when i come out of X.What i get is
> something strange characters,don't look like greeks,either like another
> language.

> Here is my locale and console setup:
> 
> LANG=el_GR.UTF-8
> LC_CTYPE="el_GR.UTF-8"
> LC_NUMERIC="el_GR.UTF-8"
> LC_TIME="el_GR.UTF-8"
> LC_COLLATE="el_GR.UTF-8"
> LC_MONETARY="el_GR.UTF-8"
> LC_MESSAGES="el_GR.UTF-8"
> LC_PAPER="el_GR.UTF-8"
> LC_NAME="el_GR.UTF-8"
> LC_ADDRESS="el_GR.UTF-8"
> LC_TELEPHONE="el_GR.UTF-8"
> LC_MEASUREMENT="el_GR.UTF-8"
> LC_IDENTIFICATION="el_GR.UTF-8"
> LC_ALL=
> 
> UNICODE=1
> KEYMAP="gr"
> BROKEN_KOMPOSE=0
> KEYMAP_CORRECTIONS="euro"
> LEGACY_CHARSET="iso.8859-7"

This is not a valid charset. It should be "iso-8859-7", see also:
'man dumpkeys'.

> FONT="iso07u-16 -m 8859-7"

Here is my console script:

KEYMAP="gr"
LANG="el_GR.utf8"
UNICODE="1"
FONT="iso07.16"
LEGACY_CHARSET="iso-8859-7"

If you like to try Ken's font, change the font to:
FONT="sigma-cyrillic-8x16"

http://www.linuxfromscratch.org/~ken/fonts/sigma-consolefonts/

> Another thing is that when i'm on X,and use [ctrl+alt+F1] i get this warning:
> 
> The XKEYBOARD keymap compiler (xkbcomp) reports:
> > Warning:          Symbol map for key <KPDL> redefined
> >                   Using last definition for conflicting fields
> Errors from xkbcomp are not fatal to the X server
> 
> I do not know if this has to do with the problem,but just
> in case...
>
This looks unrelated, probably is something with the Xkb* options in your
xorg.conf.

> Does anyone knows what kind of problem is and how can i fix it?
> 
> thank you for listening
> 
> -Nikos

Regards,
Agathoklis. 



More information about the blfs-support mailing list