mpg123-1.5.1 can't find it's libraries

zzflop at embarqmail.com zzflop at embarqmail.com
Thu Feb 4 16:16:46 PST 2010


I just completed a LFS-dev build and have been adding 
packages from BLFS.

mpg123-1.5.1 built without errors, but at run time failed 
with the following output:

[module.c:110] error: Failed to open module alsa: file not 
found
[module.c:110] error: Failed to open module oss: file not 
found
[audio.c:179] error: Unable to find a working output module 
in this list: alsa,oss
[audio.c:464] error: Failed to open audio output module
[mpg123.c:767] error: Failed to initialize output, goodbye.

I searched lfs and the mailing archives and google
and found : 

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=561857

>....For some reason, mpg123 can't find its libraries. 
> They're in /usr/lib/mpg123, so this works for me:
> $ LD_LIBRARY_PATH=/usr/lib/mpg123 mpg123 x.mp3...

> ... This  is a side-effect of a recent security-related 
> change in libltdl7. mpg123 upstream has already added a 
> fix for this problem  in 1.10.0, which is why the bug didn't 
> show up in unstable. 1.10.0-2 is about to enter testing as soon as a lagging build on 
> powerpc becomes available, and your system should be fine 
> again.In the  meantime, please stick with the workaround Nick Lewycky 
> provided earlier (ie. LD_LIBRARY_PATH=/usr/lib/mpg123 mpg123 ...).
> ...

The LD_LIBRARY_PATH worked for me also, so I assume it is 
the same problem with the libtool on my build.

I used libtool 2.2.6b on the build and have libltdl7. libs.

I tried mpg123-1.5.1 on my host machine which is LFS 6.3 
alfs and has libltdl3 and it worked fine.

I installed mpg123-1.10.0 on the dev build with no problems.

Mike H.
----



More information about the blfs-support mailing list