Missing Gtk-2.0.gir

Alonso Graterol alonso.graterol at gmail.com
Mon Feb 1 08:45:43 PST 2010


2010/2/1 Wayne Blaszczyk <wblaszcz at bigpond.net.au>:
> I believe Gtk-2.0.gir comes from gir-repository but it requires GTK2 to
> be installed first.
> I'm not familiar with Gnome being installed under /opt, so my first
> guess would be to add /opt/gnome-2.28.2/lib to /etc/ld.so.conf and
> executing ldconfig before trying to build gir-repository.
> Regards,
> Wayne.
>
>

Wayne,

Tanks for your support. I forgot to mention before that
/opt/gnome-2.28.2/lib is already added to ld.so.conf and also
gtk2+-2.18.6 was already installed by the time I am trying libunique
and gir-repository. Anyways, looking into ./configure options for gtk
I cannot find anything tat may help solve the problem.

My question would be if Gtk-2.0.gir should have been built in the
first place (I guess so) and why why it was not.

I will dig a bit on g-ir-scanner mechanics and see what I can find.

Thanks,


Alonso



More information about the blfs-support mailing list