Missing Gtk-2.0.gir

Wayne Blaszczyk wblaszcz at bigpond.net.au
Mon Feb 1 04:10:36 PST 2010


On 01/02/10 11:58, Alonso Graterol wrote:
> Hello,
> 
> I'm trying again to build Gnome at /opt and compiling libunique-1.1.6
> it stops while building unique because g-ir-scanner cannot find
> Gtk-2.0.gir.
> 
> GObject-introspection did install several .gir files but Gtk-2.0.gir.
> This would be my first place to look for...  Looking at possible
> ./configure options there is none to enable/disble gtk or similar.
> 
> Now, if I build gir-repository-0.6.5 it fails because libtool cannot
> find -lgconf-2. However libgconf.la and .so's are indeed installed at
> /opt/gnome-2.28.2/lib. If I set LD_LIBRARY_PATH accordingly before
> issuing make it makes no difference.
> 
> Google has not been of help.
> 
> I am running a CLFS x86_64 system with kernel 2.6.32.2, gcc-4.4.2.
> 
> As always, any hint to solve this is appreciated.
> 
> 
> Alonso
I believe Gtk-2.0.gir comes from gir-repository but it requires GTK2 to
be installed first.
I'm not familiar with Gnome being installed under /opt, so my first
guess would be to add /opt/gnome-2.28.2/lib to /etc/ld.so.conf and
executing ldconfig before trying to build gir-repository.
Regards,
Wayne.




More information about the blfs-support mailing list