No sound after upgrade

cliffhanger at gardener.com cliffhanger at gardener.com
Sat Nov 21 14:09:58 PST 2009


Hi

I probably asked for this, but I went ahead anyway and the outcome has been ok apart from this sound problem.

I upgraded the kernel headers(to 2.6.18) on an old 6.1 system, installed glibc 2.3.6(was 2.3.4), upgraded gcc and binutils and ran all the lfs tests.   Also upgraded to kernel 2.6.29(drivers needed) - everything was fine.   I was able to run wireless and other newbies, but I've no sound.   Straight away I upgraded to the latest alsa software as in blfs, but no luck. 

speaker-test 1.0.21

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

#lsmod | grep snd

snd_hda_codec_si3054     3956  1
snd_hda_codec_idt      49396  0
snd_hda_intel          20640  1
snd_hda_codec          37812  3 snd_hda_codec_si3054,snd_hda_codec_idt,snd_hda_intel
snd_pcm                48828  3 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec
snd_timer              15448  1 snd_pcm
snd                    40896  8 snd_hda_codec_si3054,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore               4896  1 snd
snd_page_alloc          7196  2 snd_hda_intel,snd_pcm


#alsamixer

No volume or pcm controls available, so cannot unmute.  Same result in Kmix(KDE 3.5.1)

Any ideas on this one anyone, I've googled for hours but there is nothing definitive.

thanks

MAC



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20091121/75ebd80a/attachment.html>


More information about the blfs-support mailing list