X.org imake compiling errors

Simon Brüggen metor1 at gmail.com
Tue Mar 31 07:01:39 PDT 2009


2009/3/31 Ken Moffat <ken at linuxfromscratch.org>
>
> On Mon, Mar 30, 2009 at 08:30:20PM +0200, Simon Brüggen wrote:
>
>  Two comments: 7.2 works, but it is old (7.4 is in the -dev book).
Is version 7.4 tested to work? I mean it stands in the
developement-book. And I first tried it with 7.4 but I got the same
error-message so I decided to change to a tested 7.2.
>
>  And putting something like xorg in /opt is likely to cause you more
> work later, depending what you build (things like QT still look in
> /usr/X11R6, /usr works).  But yes, I can see the sense of
> /opt/xversion if you intend to update it during the lifetime of your
> LFS-6.4 system.
Thats what I wanted but if it takes some time to build software using
x11, I can only learn from it and thats one of my main-goals
> > checking for XPROTO... configure: error: Package requirements (xproto) were
> > not met:
> >
> > No package 'xproto' found
> > </code>
> >
> > xproto.pc is located in /opt/X11-7.2/lib/pkgconfig
> >
> > root at RadioBox/opt/X11-7.2/lib/pkgconfig: echo $PKG_CONFIG_PATH
> > /usr/lib/pkgconfig:/usr/share/pkgconfig:/opt/X11-7.2/lib/pkgconfig
> > root at RadioBox/opt/X11-7.2/lib/pkgconfig: echo $XORG_CONFIG
> > --prefix=/opt/X11-7.2 --sysconfdir=/etc     --mandir=/opt/X11-7.2/share/man
> > --localstatedir=/var
> >
>
>  Something above doesn't fit.  Pkg-config is not finding xproto,
> which implies PKG_CONFIG_PATH is not correct by the time this
> buildscript runs.
But what?

"echo $PKG_CONFIG_PATH && ./configure $XORG_CONFIG" returns
"/usr/lib/pkgconfig:/usr/share/pkgconfig:/opt/X11-7.2/lib/pkgconfig"
and then starts to configure and ends with the same error message.
I tried pkg-config-0.22 and pkg-config-0.23 with glib2 if this
information helps.

Simon



More information about the blfs-support mailing list