X.org imake compiling errors

Ken Moffat ken at linuxfromscratch.org
Mon Mar 30 15:21:07 PDT 2009


On Mon, Mar 30, 2009 at 08:30:20PM +0200, Simon Brüggen wrote:
> hi,
> 
> i'm trying to install x-server on my lfs-6.4 box for a while now, but i
> always hung up at the same point.
> 
> i used a customized automatic installation script for the protocol header
> and the output looked fine for me. then i ran the same script (i'll post it
> later) for the util section but it always ends up with the same error in
> imake-1.0.2, even if i try to compile it on my own:
> 
> <code>
> root at RadioBox/sources/xc/util/imake-1.0.2: ./configure $XORG_CONFIG
> configure: loading site script /opt/X11-7.2
> sed: read error on /opt/X11-7.2: Is a directory
> ./configure: line 1216: .: /opt/X11-7.2: is a directory

 No idea what causes those errors.  They don't seem to prevent it
configuring.  You probably need to review your error handling if you
think the read error matters - I don't see that the sed you show
below is likely to be where the error comes from.

 Two comments: 7.2 works, but it is old (7.4 is in the -dev book).

 And putting something like xorg in /opt is likely to cause you more
work later, depending what you build (things like QT still look in
/usr/X11R6, /usr works).  But yes, I can see the sense of
/opt/xversion if you intend to update it during the lifetime of your
LFS-6.4 system.
> configure: loading site script /opt/X11-7.2
> sed: read error on /opt/X11-7.2: Is a directory
> ./configure: line 1216: .: /opt/X11-7.2: is a directory
> [ ... stripped ... ]
> checking for pkg-config... /usr/bin/pkg-config
> checking pkg-config is at least version 0.9.0... yes
> checking for XPROTO... configure: error: Package requirements (xproto) were
> not met:
> 
> No package 'xproto' found
> 
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> 
> Alternatively, you may set the environment variables XPROTO_CFLAGS
> and XPROTO_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> </code>
> 
> xproto.pc is located in /opt/X11-7.2/lib/pkgconfig
> 
> root at RadioBox/opt/X11-7.2/lib/pkgconfig: echo $PKG_CONFIG_PATH
> /usr/lib/pkgconfig:/usr/share/pkgconfig:/opt/X11-7.2/lib/pkgconfig
> root at RadioBox/opt/X11-7.2/lib/pkgconfig: echo $XORG_CONFIG
> --prefix=/opt/X11-7.2 --sysconfdir=/etc     --mandir=/opt/X11-7.2/share/man
> --localstatedir=/var
> 

 Something above doesn't fit.  Pkg-config is not finding xproto,
which implies PKG_CONFIG_PATH is not correct by the time this
buildscript runs.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list