X.org imake compiling errors

Simon Brüggen metor1 at gmail.com
Mon Mar 30 11:30:20 PDT 2009


hi,

i'm trying to install x-server on my lfs-6.4 box for a while now, but i
always hung up at the same point.

i used a customized automatic installation script for the protocol header
and the output looked fine for me. then i ran the same script (i'll post it
later) for the util section but it always ends up with the same error in
imake-1.0.2, even if i try to compile it on my own:

<code>
root at RadioBox/sources/xc/util/imake-1.0.2: ./configure $XORG_CONFIG
configure: loading site script /opt/X11-7.2
sed: read error on /opt/X11-7.2: Is a directory
./configure: line 1216: .: /opt/X11-7.2: is a directory
configure: loading site script /opt/X11-7.2
sed: read error on /opt/X11-7.2: Is a directory
./configure: line 1216: .: /opt/X11-7.2: is a directory
[ ... stripped ... ]
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for XPROTO... configure: error: Package requirements (xproto) were
not met:

No package 'xproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XPROTO_CFLAGS
and XPROTO_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
</code>

xproto.pc is located in /opt/X11-7.2/lib/pkgconfig

root at RadioBox/opt/X11-7.2/lib/pkgconfig: echo $PKG_CONFIG_PATH
/usr/lib/pkgconfig:/usr/share/pkgconfig:/opt/X11-7.2/lib/pkgconfig
root at RadioBox/opt/X11-7.2/lib/pkgconfig: echo $XORG_CONFIG
--prefix=/opt/X11-7.2 --sysconfdir=/etc     --mandir=/opt/X11-7.2/share/man
--localstatedir=/var

hope you can help me to solve this problem,
greetings from germany

here's my script:
<code>
section=$1
version=7.2
mkdir $section
cd $section

source /etc/profile

if [ "$2" != "no-dl" ]
then
  # download and check packages
  grep -v '^#' ../${section}-${version}.wget | wget -i- -c \
      -B http://xorg.freedesktop.org/releases/individual/${section}/<http://xorg.freedesktop.org/releases/individual/$%7Bsection%7D/>
  md5sum -c ../${section}-${version}.md5
  if [ "$3" = "sleep" ] || [ "$4" = "sleep" ]; then
    sleep 2
  fi
fi

if [ "$2" != "no-inst" ]
then
  # build packages
  for package in $(grep -v '^#' ../${section}-${version}.wget)
  do
    packagedir=$(echo $package | sed 's/.tar.bz2//')
    tar -xf $package
    cd $packagedir
    if ! ./configure $XORG_CONFIG; then echo; echo "###########"; echo
"$packagedir/configure $XORG_CONFIG"; echo "made a error"; exit; fi
    if ! make; then echo; echo "###########"; echo "$package's 'make' made a
error"; exit; fi
    if ! make install; then echo; echo "###########"; echo "$package's 'make
install' made a error"; exit; fi
    echo Configured with $XORG_CONFIG
    if [ "$3" = "sleep" ] || [ "$4" = "sleep" ]; then
      sleep 3
    fi
    cd ..
    rm -rf $packagedir
    if [ "$3" = "delete-packages" ] || [ "$4" == "delete-packages" ]; then
      rm -f $package
    fi
  done 2>&1 | tee -a ../xorg-${section}-compile.log #log the entire loop
    fi
  done 2>&1 | tee -a ../xorg-${section}-compile.log #log the entire loop
fi
</code>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20090330/cb5e9b4c/attachment.html>


More information about the blfs-support mailing list