libqalculate-0.9.6 for kdeedu-4.2.1

Ken Moffat zarniwhoop at ntlworld.com
Sun Mar 29 08:51:28 PDT 2009


On Sun, Mar 29, 2009 at 03:29:10PM +0100, lux-integ wrote:
> Greetings
> 
> I am trying to compile libqalculate-0.9.6 (host is AMD64/64-bit-only  CBLFS) 
> Kernel2.6.27.2 gcc4.3.2).  It is needed for kdeedu-4.2.1.
> 
> -----------------------
> firstly the dependency cln-1.2.2 is installed in /usr  ( it compiles and 
> installs trouble free and there is no  /usr/bin/cls-config)  
> 
> secondly attempts to compile libqalculate-0.9.6  is met  with  the following:-
> 
> 
> /usr/lib/gcc/x86_64-unknown-linux-gnu/4.3.2/../../../../include/c++/4.3.2/backward/backward_warning.h:33:2: 
> warning: #warning This file includes at least one deprecated or antiquated 
> header which may be removed without further notice at a future date. Please 
> use a non-deprecated interface with equivalent functionality instead. For a 
> listing of replacement headers and interfaces, consult the file 
> backward_warning.h. To disable this warning use -Wno-deprecated.
> Number.cc:31: error: 'void cln::cl_abort()' should have been declared 
> inside 'cln'
> Number.cc: In member function 'int Number::intValue(bool*) const':
> Number.cc:607: error: 'INT_MAX' was not declared in this scope
> Number.cc:610: error: 'INT_MIN' was not declared in this scope
> Number.cc: In member function 'bool Number::binomial(const Number&, const 
> Number&)':
> Number.cc:2087: error: 'INT_MAX' was not declared in this scope
> make[2]: *** [Number.lo] Error 1
> 
 That INT_MAX error ought to be fixable, perhaps by
http://cvs.archlinuxppc.org:7647/viewvc/Extra/extra/lib/libqalculate/libqalculate-0.9.6-gcc4.3.patch?view=markup&sortby=log
 - that just happened to be the first link I found which took me to a
list of patches for libqalculate, I don't think it's ppc-specific.

 Perhaps you've already done that to get to this next part -

> ((  the  ageing libqalculate-0.9.6    still looks for   /usr/bin/cls-config) 
> 
> digging on the internet  suggest a) modern cln  no longer has  
> ~/bin/cln-config  but ~/lib/cln.pc  AND it is possible to  'create' a 
> usr/bin/cln-config.  However   when I    copy  /usr/lib/pkgconfig/cln.pc  
> to /usr/lib/cln.config  and do the following:-
> 
> a)  change permissions  of /usr/bin/cln-config to 644   the configure script 
> of linqalculate-0.9.6  complains with  "/usr/bin/cln-config permission 
> denied"
> 
> b) change permissions  of /usr/bin/cln-config to 777   the configure script of 
> linqalculate-0.9.6  complains   that lines 7-11  /usr/bin/cln-config are 
> incorrect
> 
> (and the compiler output is as above) Clearly something is wrong.  
> I even tried the patch :-  libqalculate-0.9.6-cln-config.patch  but it made no 
> difference
> 
> I did a search for svn/git libqalculate  modern versions  but the project 
> seems to  have ceased development.  if someonw knows  a) of a how to get 
> libqalculate to bypass ~/bin/cln-config  or b) how to generate a usable file 
> from  cln.pc OR (c) a useful patch to overcome the problem OR (d) where one 
> can get a modern  svn/cvs/git  version of libqalculate that works with modern 
> cln.........
> 
> .......your help/suggestions/info will be appreciated
> 
> lux-integ

 So, not only does current kde need not-properly-released tools to
build it, it also needs defunct packages.  Sometimes, I start to
despair.

 If the cln-config patch you're using is anything like the one in
the same arch /libqalculate/ directory, you need to invoke the
autofoo magic after applying it, before you run configure.  The
normal shotgun approach is to just run 'autoreconf'.  On the one
package where I currently use that, it wasn't sufficient and I had
to follow it with "libtoolize -f'.  I'm led to believe that should
only very rarely be necessary (in that case, I found it in a gentoo
ebuild).

 If you haven't tried autoreconf, use clean source, apply both the
patches, autoreconf, configure, make.  If that is not sufficient,
use clean source [critical in this case!], reapply the patches,
autoreconf and then 'libtoolize -f' before configure.

HTH
ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list