liba52 make fail//xmms compile///tunepimp(s)

lux-integ lux-integ at btconnect.com
Thu Mar 26 10:27:26 PDT 2009


On Saturday 20 December 2008 09:31:40 pm b-vol wrote:

> ####### attempt to install libtunepimp-0.5.3   (as alternative)
> a) libofa patched is recommended.   Below  is the result with the  patch
> ( libofa-0.9.3-uopdate_to_r8438.patch   some 3mBytes!  large   )  correctly
> applied:-
>
> ###libofa-0.9.3-patched)
>  g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../include -g -O2 -Wall -g -MT
> signal_op.lo -MD -MP -MF .deps/signal_op.Tpo -c
> signal_op.cpp  -fPIC -DPIC -o .libs/signal_op.o
> signal_op.cpp: In member function 'void Signal_op::RemoveSilence(double,
> double)':
> signal_op.cpp:169: error: 'abs' was not declared in this scope
> signal_op.cpp:192: error: 'abs' was not declared in this scope
> signal_op.cpp: In member function 'void Signal_op::Normalize()':
> signal_op.cpp:301: error: 'abs' was not declared in this scope
> make[3]: *** [signal_op.lo] Error 1
>
> ###atttempt to compile tunepimp-0.5.3 without libofa (understandably) leads
> to :
>
> ..checking for ofa_get_version in -lofa... no
> *
> *  The Open Fingerprint Architecture library library needs
> *  to be installed. Please download the library from
> *  http://www.musicdns.org/downloads
--------------------------------------------------------------
I have found  patches  here:-  
http://packages.pardus.org.tr/info/pardus-2008/source/libofa.html
which are useful  AND libofa-0.5.3   now compiles.

AND  libtunepimp-0.5.3-gcc43.patch at :-  
http://cvs.fedoraproject.org/viewvc/devel/libtunepimp/

so  libtunepimp-0.5.3  (needed by kdemultimedia-4.2.1) compiles.
Hope this is of help  to those fiddling with  kde-4.2.1.


sincerely
lux-integ
ps  xmms-1.2.11 also compiles if  the  configure script  does not call the 
installed libiconv  (thanks to KenMoffat for the advice).







More information about the blfs-support mailing list