upgrading glib2 and gtk2
zarniwhoop at ntlworld.com
Wed Apr 29 11:48:21 PDT 2009
On Wed, Apr 29, 2009 at 10:43:59AM -0500, David Jensen wrote:
> On Wed, 29 Apr 2009 12:58:42 +0100
> lux-integ <lux-integ at btconnect.com> wrote:
> > Greetings,
> > I currently have gtk-2.14.3 installed in /opt/gtk2. I want to
> > upgrade to gtk-2.16.1 ( for newer version of firefox, geda etc) I
> > also have glib-2.18.3
> > QUESTIONS:
> > a)Regarding glib2 can I just install 2.20.1 over the old version of
> > glib2.18.3 or is 'uninstallation' and post-install symnlinks
> > required?
> > b) regarding gtk-2.16.1; is it backward compatible to
> > version-2.14.3 allowing a symlink to the newer version? Or must I
> > keep the old 2.14.3 hanging around as quite a few things depend
> > on it?
> > suggestions welcomed.
> I'm thinking just install them, latest glib, cairo, pango, atk, and gtk.
> but I'm fearless s/fear/clue/
> proceed at your own risk
It's an interesting question. I have no idea if they will be fully
backwards compatible. If I was doing it, I'd steer clear of
'uninstall' and rename any old libraries so that they won't be found
(and then remove them once everything is known to work).
Unfortunately, there are no hard and fast rules about versioning -
I've just updated poppler and xine-lib on one of my systems to cope
with the latest vulnerabilities - poppler went from 0.10.1 to 0.10.6
and just overwrote the .so file with a newer one bearing the same
number. Xine-lib (188.8.131.52 -> 184.108.40.206) dropped in a new .so.
Eventually, upgrades produce changed interfaces and eventually all
the relevant configure scripts get modified so that the latest
versions know what to do. The corollary of that is that older
versions still try to use the old interface. So, given that the OP
has installed a _lot_ of things, I would not be surprised to hear
there is breakage somewhere.
It will probably be educational to try!
das eine Mal als Tragödie, das andere Mal als Farce
More information about the blfs-support