update on OpenOffice-3.0.1, JAVA, AMDE64//now OK but cant find binaries

lux-integ lux-integ at btconnect.com
Tue Apr 28 05:21:48 PDT 2009


On Monday 27 April 2009 12:22:36 pm lux-integ wrote:

> Thanks very much   I removed  --disable-qadevooot   from the configure
> script and the build now  'appears' to go  to completion:-
>
> ###########  I get this at the end
> packimages -- version: 1.17
> packimages: packing  ../unxlngx6.pro/bin/images_classic.zip finished.
> deliver -- version: 1.130
> Module 'packimages' delivered successfully. 8 files copied, 0 files
> unchanged =============
> Building module instsetoo_native
> ~/instsetoo_native/inc_openoffice/unix
> mkout -- version: 1.8
> -------------
> ~/instsetoo_native/inc_openoffice/windows/msi_languages
> -------------
> ~/instsetoo_native/macosx
> Nothing to build for OS LINUX and GUIBASE unx
> ~/instsetoo_native/util
> -------------
> No EPM: do no packaging at this stage
> rmdir /tmp/7113
> ##################
I   did two things   and the build now generates      the required 
binaries/libraries etc.  I did 
a): removed   --disable-epm  from the configure script
b): added  before   bootstrap  (before build)  
export LOCALINSTALLDIR="/opt/openoffice-3.0.1"
export PKGFORMAT="installed"

there is now a OOO300_m15/instsetoo_native/unxlngx6.pro/OpenOffice/native  
directory

but
 x643: # ls OOO300_m15/instsetoo_native/unxlngx6.pro/OpenOffice/native 
change_filename                                hidden_file  patchsoname_file   
stripped
gid_Starregistry_Services_Rdb_rdb              install      profiles           
zip
gid_Starregistry_Services_Rdb_servicesrdb      listfile     replace_file
gid_Starregistry_Services_Rdb_Ure_servicesrdb  logging      replace_scpaction
x643: #

and the install/en-US is empty
x643: # ls  
OOO300_m15/instsetoo_native/unxlngx6.pro/OpenOffice/native/install/en-US
x643: #
 
On the other hand  I duly get  two directories  at the end of he build.
A) /opt/openoffice-3_download.0.1
this contains OOo_3.0.1_090428_unxlngx6_install.tar.gz
B) /opt/openoffice-3.0.1
this contains the directory linux-2.6-x86_64
(so  A)  seems to to be B)  archived)

considering just  B):-
x643: # ls linux-2.6-x86_64/buildroot/opt
openoffice.org  openoffice.org3

x643: # 
ls  /opt/openoffice-3.0.1/linux-2.6-x86_64/buildroot/opt/openoffice.org/basis3.0/program
list   libraries some ~464 (too numerous to list here)


x643: # 
ls /opt/openoffice-3.0.1/linux-2.6-x86_64/buildroot/opt/openoffice.org3/program
about.bmp      intro.bmp         resource  sdraw     smath        sofficerc  
unoinfo     versionrc
bootstraprc    libnpsoplugin.so  sbase     setuprc   soffice      spadmin    
unopkg
fundamentalrc  redirectrc        scalc     simpress  soffice.bin  swriter    
unopkg.bin
x643:/home/pcbman #


QUESTION:

the 'extrapolated'  BLFS recipe for Openoffice-2.3.1 installation suggests:-
cp -r -v openoffice.org3.0.1 /opt/openoffice-3.0.1

for appl in sbase scalc sdraw simpress smath soffice spadmin swriter
do
    ln -v -sf /opt/openoffice-3.0.1/program/$appl /usr/bin/$appl
done



in view of the changed   setup here,  does one do?:

cd  /opt/openoffice-3.0.1/linux-2.6-x86_64/buildroot/opt/openoffice.org3/program

for appl in sbase scalc sdraw simpress smath soffice spadmin swriter
do

   ln -v - 
sf /opt/openoffice-3.0.1/linux-2.6-x86_64/buildroot/opt/openoffice.org3/program/$appln  /usr/bin/$appln
    
done


OR is   there a  better  way ?

suggestions welcomed

sincerely
lux-integ
>
>
>
> shows no OpenOffice directory in instsetoo_native/unixlngx6.pro  nor  in
> OOO300_m15/instsetoo_native/inc_openoffice/unix
>
> some guidance would be appreciated.
>
>
> sincerely
>
> lux-ineg
>
> > -- DJ Lucas





More information about the blfs-support mailing list