ORBit2-2.14.7 does not build

Ken Moffat zarniwhoop at ntlworld.com
Thu Apr 23 15:56:47 PDT 2009


On Thu, Apr 23, 2009 at 11:02:43PM +0200, Dr. Edgar Alwers wrote:
> Hi Ken,
> 
> I am sorry, I am reporting bugs continuosly and becoming nasty ;-)
> The version ORBit-2.14.7 mentioned in the BLFS book svn-20090409 chapter 29 
> does not compile. Reported error was
> 
> from orbit-interface-common.c:9:
> ../../../include/orbit/GIOP/giop-endian.h:16: error: static declaration 
> of 'giop_byteswap' follows non-static declaration
> 
> Version ORBit-2.14.17 from 05-Mar-2009 builds perfectly.
> This again as remainder. Perhaps you can change the pointer in the next 
> edition of the book.
> 
> Regards
> Edgar

 It's part of ticket #2482 (well, 2.14.16 was the last specific
version mentioned there and is also what I'm currently using).  Not
mine (I only build a small part of gnome), and I've pretty much
done all I can for 6.4:  of my remaining tickets, 1 is no big deal
or urgency (gnumeric), 1 doesn't work with current libxml2
(abiword-2.6), and the third (rsync) doesn't work adequately for
me in the latest release (bug fixed, latest snapshot seems ok, but
we don't do unreleased versions and the old version in the book is
ok).

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list