gnash [ was Re: KDE4 ? ]

lux-integ lux-integ at btconnect.com
Mon Apr 20 17:35:57 PDT 2009


On Monday 20 April 2009 11:49:17 pm Ken Moffat wrote:
> On Mon, Apr 20, 2009 at 08:39:10PM +0100, lux-integ wrote:
> > I am still struggling with gnash
>
>  Anything I can help with ? 

 I installed all the gnash dependencies I believe.  Configure yields the 
folowing:-

#######
Configured paths for x86_64-unknown-linux-gnu are:
        DocBook document processing enabled (for "make html" and "make pdf")
        QT4 flags 
are: -I/opt/qt-4.5.0/include -I/opt/qt-4.5.0/include/QtCore -I/opt/qt-4.5.0/include/QtGui   -I/opt/qt-4.5.0/include/QtCore -I/opt/qt-4.5.0/include/QtGui -I/opt/qt-4.5.0/include/QtXml -I/opt/qt-4.5.0/include/QtDBus -I/opt/qt-4.5.0/include/QtNetwork -I/opt/qt-4.5.0/include/QtOpenGL -I/opt/qt-4.5.0/include/QtScript -I/opt/qt-4.5.0/include/QtSql -I/opt/qt-4.5.0/include/QtTest -I/opt/qt-4.5.0/include/QtSvg -I/opt/qt-4.5.0/include/QtWebKit
        QT4 libs are: -L/opt/qt-4.5.0/lib -lQtGui -lQtCore  
        KDE 4.x flags are: -I/opt/kde-4.2.1/include
        KDE 4.x libs are: -L/opt/kde-4.2.1/lib -lkdeui
        JPEG flags are: default include path
        JPEG libs are: -ljpeg 
        GIF flags are: default include path
        GIF libs are: -lgif 
        PNG flags are: default include path
        PNG libs are: -lpng12  
        OpenGL flags are: -I/usr/X11R6/include
        OpenGL libs are: -L/usr/X11R6/lib -lGL -lGLU
        GtkGLExt flags 
are: -I/usr/include/freetype2 -I/usr/include/libpng12 -I/opt/include/pango-1.0 -I/usr/X11/include -I/opt/include/glib-2.0 -I/opt/lib/glib-2.0/include -I/opt/include/cairo -I/opt/include/atk-1.0 -I/usr/X11R7.4/include/pixman-1 -I/usr/X11R7.4/include -I/opt/gtk2143/include/gtkglext-1.0 -I/opt/gtk2143/lib/gtkglext-1.0/include -I/opt/gtk2143/include/gtk-2.0 -I/opt/gtk2143/lib/gtk-2.0/include   
        GtkGLExt libs 
are: -lgtkglext-x11-1.0 -lgdkglext-x11-1.0 -lGLU -lGL -lXmu -lXt -lSM -lICE -lgtk-x11-2.0 -lpangox-1.0 -lX11 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lz -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0  
        GTK2 flags 
are: -I/usr/include/freetype2 -I/usr/include/libpng12 -I/opt/include/atk-1.0 -I/opt/include/cairo -I/opt/include/pango-1.0 -I/opt/include/glib-2.0 -I/opt/lib/glib-2.0/include -I/usr/X11R7.4/include/pixman-1 -I/usr/X11R7.4/include -I/opt/gtk2143/include/gtk-2.0 -I/opt/gtk2143/lib/gtk-2.0/include   
        GTK2 libs 
are: -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lz -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0  
        Pango flags 
are: -I/opt/include/pango-1.0 -I/usr/X11/include -I/opt/include/glib-2.0 -I/opt/lib/glib-2.0/include  
        Pango libs 
are: -lpangox-1.0 -lX11 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0  
        GLib flags are: -I/opt/include/glib-2.0 -I/opt/lib/glib-2.0/include   
        GLib libs are: -L/opt/lib -lglib-2.0  
        ATK flags 
are: -I/opt/include/atk-1.0 -I/opt/include/glib-2.0 -I/opt/lib/glib-2.0/include  
        ATK libs are: -latk-1.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0  
        Gstreamer flags 
are: -pthread -I/usr/include/libxml2 -I/opt/include -I/opt/include/glib-2.0 -I/opt/lib/glib-2.0/include -I/opt/gstreamer-0.10.21/include/gstreamer-0.10  
        Gstreamer libs 
are: -lgstreamer-0.10 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lxml2 -lglib-2.0   -lgstpbutils-0.10
        SDL flags are: -I/opt/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT
        SDL libs are: -L/opt/lib -Wl,-rpath,/opt/lib -lSDL -lpthread
        POSIX Threads flags are: -pthread
        POSIX Threads lib is: -lpthread
        You have version 0.8.8 of the DocBook2X tools.
        CURL flags are: default include path
        CURL libs are: -lcurl
        Speex flags are: -I/opt/include  
        Speex libs are: -lspeex -lm  
        BOOST flags are: -I/usr/include/boostX-1_38
        BOOST libs 
are: -L/usr/lib64 -lboost_thread-gcc43-mt-1_37 -lboost_date_time-gcc43-mt-1_37
        BOOST Extra libs are:  -lboost_serialization-gcc43-mt-1_37
        MING flags are -I/usr/local/include
        MING libs are -L/usr/local/lib -lz -lm -lgif -lpng -lming
        MING version code is 00040200
        MAKESWF is /usr/local/bin/makeswf
        MTASC is /usr/local
        MTASC CLASSPATH is /usr/share/ocaml/mtasc/std
        HAXE is /usr/local
        HAXE CLASSPATH is /usr/share/haxe/
        SWFMILL is /usr/local/bin/swfmill
        SWFC is /usr/local/bin/swfc
        PYTHON is /usr/bin/python
        PERL is /usr/bin/perl
        CSOUND is /usr/local/bin/csound
        Z flags are: default include path
        Z libs are: -lz 
        FreeType flags are: -I/usr/include/freetype2  
        FreeType libs are: -lfreetype -lz  
        Fontconfig flags are:  
        Fontconfig libs are: -lfontconfig  
        DEJAGNU's runtest is /usr/bin/runtest
        XPCOM flags are: -I/opt/firefox-3.0.5/include/firefox-3.0.5/unstable
        XPCOM libs 
are: -L/opt/firefox-3.0.5/lib/firefox-devel-3.0.5/sdk/lib -lxpcomglue_s -lnspr4 -lplds4
        XPIDL path is: xpidl
        NSPR flags are: -I/usr/include/nspr  
        NSPR libs are: -Wl,-R/usr/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl 

###########
when to type make,  it compiles for a while then fails with the following 
message:-

#######
referenced in section 
`.gnu.linkonce.r._ZN5boost11multi_index6detail13ordered_indexINS0_13composite_keyIN5gnash8PropertyENS0_6memberIS5_mXadL_ZNS5_5mNameEEEEENS6_IS5_mXadL_ZNS5_10mNamespaceEEEEENS_6tuples9null_typeESA_SA_SA_SA_SA_SA_SA_EESt4lessINS0_20composite_key_resultISB_EEENS1_9nth_layerILi1ES5_NS0_10indexed_byINS0_14ordered_uniqueISB_N4mpl_2naESK_EENSI_INS0_3tagINS4_12PropertyList5oTypeESK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_EENS6_IS5_iXadL_ZNS5_8mOrderIdEEEEESK_EESK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_EESaIS5_EEENS_3mpl7vector0ISK_EENS1_18ordered_unique_tagEE16delete_all_nodesEPNS1_18ordered_index_nodeINS10_INS1_15index_node_baseIS5_ST_EEEEEE' 
of ../libcore/vm/.libs/libgnashvm.a(Machine.o): defined in discarded section 
`.gnu.linkonce.t._ZN5boost11multi_index6detail13ordered_indexINS0_13composite_keyIN5gnash8PropertyENS0_6memberIS5_mXadL_ZNS5_5mNameEEEEENS6_IS5_mXadL_ZNS5_10mNamespaceEEEEENS_6tuples9null_typeESA_SA_SA_SA_SA_SA_SA_EESt4lessINS0_20composite_key_resultISB_EEENS1_9nth_layerILi1ES5_NS0_10indexed_byINS0_14ordered_uniqueISB_N4mpl_2naESK_EENSI_INS0_3tagINS4_12PropertyList5oTypeESK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_EENS6_IS5_iXadL_ZNS5_8mOrderIdEEEEESK_EESK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_SK_EESaIS5_EEENS_3mpl7vector0ISK_EENS1_18ordered_unique_tagEE16delete_all_nodesEPNS1_18ordered_index_nodeINS10_INS1_15index_node_baseIS5_ST_EEEEEE' 
of
......
`.gnu.linkonce.t._ZN5gnash12PropertyListD1Ev' 
of ../libcore/vm/.libs/libgnashvm.a(Machine.o)
collect2: ld returned 1 exit status
make[3]: *** [libgnashcore.la] Error 1
######


help will be much appreciated.

>  I only use gnash with firefox so I 
> might be missing something needed for it to work in konqueror.
>
>  The apparent deps I have are gstreamer with base, good, ffmpeg
> plugins (can't remember which plugins are needed by gnash), I also
> have evolution-data-server, totem-pl-parser, totem (but, perhaps
> totem isn't needed by gnash), agg (--enable-ctrl --enable-gpc),
> gnash (--with-npapi-plugin-dir=/usr/lib/mozilla/plugins
> --enable-render=cairo --enable-media=gst).
>
>  On the face of it, I'm not even _using_ agg, but who knows.
>
> ĸen
> --
> das eine Mal als Tragödie, das andere Mal als Farce





More information about the blfs-support mailing list